summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Fernando Lopez Jr <fernando.lopezjr@gmail.com>2017-04-08 23:40:23 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-13 07:27:45 +0700
commita44a15cd1fc29d9b7a5231d61ad6b67296807bb5 (patch)
treee4c07757427a57de36695d7d835e7611f4fc544b /system
parent4fe5c5562857643c461eb3b5ef5b13fdbce5d4a7 (diff)
downloadslackbuilds-a44a15cd1fc29d9b7a5231d61ad6b67296807bb5.tar.gz
slackbuilds-a44a15cd1fc29d9b7a5231d61ad6b67296807bb5.tar.xz
system/capstone: Added (disassembly framework).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/capstone/README7
-rw-r--r--system/capstone/capstone.SlackBuild107
-rw-r--r--system/capstone/capstone.info10
-rw-r--r--system/capstone/slack-desc19
4 files changed, 143 insertions, 0 deletions
diff --git a/system/capstone/README b/system/capstone/README
new file mode 100644
index 0000000000..500f0043f3
--- /dev/null
+++ b/system/capstone/README
@@ -0,0 +1,7 @@
+Capstone is a lightweight multi-platform, multi-architecture disassembly
+framework.
+
+Multi-architectures: Arm, Arm64 (Armv8), M68K, Mips, PowerPC, Sparc,
+SystemZ, XCore & X86 (including X86_64).
+
+Distributed under the open source BSD license.
diff --git a/system/capstone/capstone.SlackBuild b/system/capstone/capstone.SlackBuild
new file mode 100644
index 0000000000..e4fe1bf7db
--- /dev/null
+++ b/system/capstone/capstone.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/sh
+
+# Slackware build script for capstone
+
+# Copyright 2016 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=capstone
+VERSION=${VERSION:-3.0.5_rc2}
+SRCVER=$(echo $VERSION | tr _ -)
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TMP/$PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
+cd $PRGNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e "s/DESTINATION lib/DESTINATION lib$LIBDIRSUFFIX/" CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCAPSTONE_ARM_SUPPORT=1 \
+ -DCAPSTONE_ARM64_SUPPORT=1 \
+ -DCAPSTONE_MIPS_SUPPORT=1 \
+ -DCAPSTONE_PPC_SUPPORT=1 \
+ -DCAPSTONE_SPARC_SUPPORT=1 \
+ -DCAPSTONE_SYSZ_SUPPORT=1 \
+ -DCAPSTONE_XCORE_SUPPORT=1 \
+ -DCAPSTONE_X86_SUPPORT=1 \
+ -DCAPSTONE_X86_ATT_DISABLE=1 \
+ -DCAPSTONE_BUILD_STATIC=0 \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make VERBOSE=1
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COMPILE* LICENSE* README TODO RELEASE_NOTES HACK.TXT ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/capstone/capstone.info b/system/capstone/capstone.info
new file mode 100644
index 0000000000..89ad56d894
--- /dev/null
+++ b/system/capstone/capstone.info
@@ -0,0 +1,10 @@
+PRGNAM="capstone"
+VERSION="3.0.5_rc2"
+HOMEPAGE="http://www.capstone-engine.org"
+DOWNLOAD="https://github.com/aquynh/capstone/archive/3.0.5-rc2/capstone-3.0.5-rc2.tar.gz"
+MD5SUM="d8ebb36e9880c270e2fbb2770956917f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/system/capstone/slack-desc b/system/capstone/slack-desc
new file mode 100644
index 0000000000..482b1d1402
--- /dev/null
+++ b/system/capstone/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |----handy-ruler-------------------------------------------------------|
+capstone: capstone (disassembly framework)
+capstone:
+capstone: Capstone is a lightweight multi-platform, multi-architecture
+capstone: disassembly framework.
+capstone:
+capstone:
+capstone:
+capstone:
+capstone:
+capstone:
+capstone: