summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/nnls-chroma/nnls-chroma.SlackBuild17
-rw-r--r--audio/nnls-chroma/nnls-chroma.info6
-rw-r--r--audio/nnls-chroma/use_system_vamp_sdk.diff12
3 files changed, 11 insertions, 24 deletions
diff --git a/audio/nnls-chroma/nnls-chroma.SlackBuild b/audio/nnls-chroma/nnls-chroma.SlackBuild
index feb04f6977..ff01820873 100644
--- a/audio/nnls-chroma/nnls-chroma.SlackBuild
+++ b/audio/nnls-chroma/nnls-chroma.SlackBuild
@@ -7,7 +7,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
PRGNAM=nnls-chroma
-VERSION=${VERSION:-0.2.1}
+VERSION=${VERSION:-1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -43,7 +43,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tgz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -52,21 +52,20 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-patch -p1 < $CWD/use_system_vamp_sdk.diff
-
# Look for chord.dict in correct path on x86_64
sed -i "s,/usr/lib/vamp,/usr/lib$LIBDIRSUFFIX/vamp," chromamethods.cpp
-make -f Makefile.linux
+make -f Makefile.linux VAMP_SDK_DIR=/usr/include/vamp-sdk
# no 'make install'...
+# 20160803 bkw: chord.dict is gone. there's a chord.dictold, but it has
+# fewer chords than the defaults hard-coded in chromamethods.cpp. I'll
+# install chord.dictold in the doc directory, in case someone needs it.
mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/vamp
-cp -a chord.dict $PRGNAM.so $PRGNAM.n3 $PRGNAM.cat $PKG/usr/lib$LIBDIRSUFFIX/vamp
+cp -a $PRGNAM.so $PRGNAM.n3 $PRGNAM.cat $PKG/usr/lib$LIBDIRSUFFIX/vamp
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README COPYING *.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a chord.dictold README COPYING *.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/audio/nnls-chroma/nnls-chroma.info b/audio/nnls-chroma/nnls-chroma.info
index 702726219f..3dba35ecaa 100644
--- a/audio/nnls-chroma/nnls-chroma.info
+++ b/audio/nnls-chroma/nnls-chroma.info
@@ -1,8 +1,8 @@
PRGNAM="nnls-chroma"
-VERSION="0.2.1"
+VERSION="1.1"
HOMEPAGE="http://isophonics.net/nnls-chroma"
-DOWNLOAD="http://isophonics.net/sites/isophonics.net/files/nnls-chroma-0.2.1.tgz"
-MD5SUM="f25351476d629fe48e48cbbe62fe95fb"
+DOWNLOAD="https://code.soundsoftware.ac.uk/attachments/download/1691/nnls-chroma-1.1.tar.gz"
+MD5SUM="6f9267ab2b247e4a63f03d1fd17858dc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="vamp-plugin-sdk"
diff --git a/audio/nnls-chroma/use_system_vamp_sdk.diff b/audio/nnls-chroma/use_system_vamp_sdk.diff
deleted file mode 100644
index 664f9bda22..0000000000
--- a/audio/nnls-chroma/use_system_vamp_sdk.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur nnls-chroma-0.2.1/Makefile.linux nnls-chroma-0.2.1.patched/Makefile.linux
---- nnls-chroma-0.2.1/Makefile.linux 2010-12-07 08:05:16.000000000 -0500
-+++ nnls-chroma-0.2.1.patched/Makefile.linux 2011-05-30 22:46:39.000000000 -0400
-@@ -13,7 +13,7 @@
- CXXFLAGS = $(ARCHFLAGS) -I$(VAMP_SDK_DIR) -Wall -fPIC
- PLUGIN_EXT = .so
- PLUGIN = $(PLUGIN_LIBRARY_NAME)$(PLUGIN_EXT)
--LDFLAGS = -shared -Wl,-soname=$(PLUGIN) $(VAMP_SDK_DIR)/libvamp-sdk.a -Wl,--version-script=vamp-plugin.map
-+LDFLAGS = -shared -Wl,-soname=$(PLUGIN) -lvamp-sdk -Wl,--version-script=vamp-plugin.map
-
-
- $(PLUGIN): $(PLUGIN_CODE_OBJECTS)