summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libraries/SFML/SFML.SlackBuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/libraries/SFML/SFML.SlackBuild b/libraries/SFML/SFML.SlackBuild
index c8d88b1f2e..bafd1311b9 100644
--- a/libraries/SFML/SFML.SlackBuild
+++ b/libraries/SFML/SFML.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=SFML
VERSION=${VERSION:-2.4.2}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -76,6 +76,7 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DSFML_INSTALL_PKGCONFIG_FILES=1 \
-DCMAKE_BUILD_TYPE=Release ..
make
@@ -85,13 +86,6 @@ cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-## Patches ##
-
-# -DLIB_SUFFIX is ignored (issue on SFML forum filed). Patch CMakeLists as needed.
-if [ "$LIBDIRSUFFIX" = "64" ]; then
- mv ${PKG}/usr/lib ${PKG}/usr/lib64
-fi
-
# a cmake module from SFML is needed for SFGUI to build
# but it is not installed by default for some reason
CMAKEMODPATH=$(dirname `find /usr/share/ -type f -name "CMake.cmake"`)