summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/pysetuptools/README8
-rw-r--r--python/pysetuptools/pysetuptools.SlackBuild68
-rw-r--r--python/pysetuptools/pysetuptools.info10
-rw-r--r--python/pysetuptools/slack-desc19
4 files changed, 0 insertions, 105 deletions
diff --git a/python/pysetuptools/README b/python/pysetuptools/README
deleted file mode 100644
index 1cee00b116..0000000000
--- a/python/pysetuptools/README
+++ /dev/null
@@ -1,8 +0,0 @@
-pysetuptools (a collection of enhancements to Python distutils)
-Note: the name of the source package is 'setuptools'. Since
-'setuptools' is such a generic name, this package uses the name
-'pysetuptools' to avoid any potential future conflicts. The actual
-installation paths and file names are not modified in any way.
-
-setuptools allow you to more easily build and distribute Python
-packages, especially ones that have dependencies on other packages.
diff --git a/python/pysetuptools/pysetuptools.SlackBuild b/python/pysetuptools/pysetuptools.SlackBuild
deleted file mode 100644
index 0ffafc259e..0000000000
--- a/python/pysetuptools/pysetuptools.SlackBuild
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-
-# Copyright 2013-2015 Audrius Kažukauskas <audrius@neutrino.lt>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pysetuptools
-VERSION=${VERSION:-18.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=setuptools
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$SRCNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pysetuptools/pysetuptools.info b/python/pysetuptools/pysetuptools.info
deleted file mode 100644
index c459daab00..0000000000
--- a/python/pysetuptools/pysetuptools.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pysetuptools"
-VERSION="18.2"
-HOMEPAGE="https://pypi.python.org/pypi/setuptools"
-DOWNLOAD="https://pypi.python.org/packages/source/s/setuptools/setuptools-18.2.tar.gz"
-MD5SUM="52b4e48939ef311d7204f8fe940764f4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
diff --git a/python/pysetuptools/slack-desc b/python/pysetuptools/slack-desc
deleted file mode 100644
index f17cc0b281..0000000000
--- a/python/pysetuptools/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pysetuptools: pysetuptools (a collection of enhancements to Python distutils)
-pysetuptools:
-pysetuptools: Easily build, install, upgrade, and uninstall Python packages!
-pysetuptools:
-pysetuptools: Setuptools is a fully-featured, actively-maintained, and stable
-pysetuptools: library designed to facilitate packaging Python projects, where
-pysetuptools: packaging includes Python package and module definitions,
-pysetuptools: distribution package metadata, test hooks, project installation,
-pysetuptools: platform-specific details, and Python 3 support.
-pysetuptools:
-pysetuptools: