summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/tint/README7
-rw-r--r--games/tint/doinst.sh7
-rw-r--r--games/tint/slack-desc19
-rw-r--r--games/tint/tint.SlackBuild100
-rw-r--r--games/tint/tint.info10
5 files changed, 143 insertions, 0 deletions
diff --git a/games/tint/README b/games/tint/README
new file mode 100644
index 0000000000..d903ad2b32
--- /dev/null
+++ b/games/tint/README
@@ -0,0 +1,7 @@
+TINT Is Not Tetris
+
+As the title suggests, this is a clone of the original tetris game.
+
+The game is as close to the original as possible, but there are a few
+differences. Nevertheless, it's probably the closest to the original
+that you'll ever find in the UNIX world.
diff --git a/games/tint/doinst.sh b/games/tint/doinst.sh
new file mode 100644
index 0000000000..7023b60665
--- /dev/null
+++ b/games/tint/doinst.sh
@@ -0,0 +1,7 @@
+touch /var/games/tint.scores
+chown root:games /var/games/tint.scores
+chmod 0664 /var/games/tint.scores
+
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/games/tint/slack-desc b/games/tint/slack-desc
new file mode 100644
index 0000000000..9dac22254e
--- /dev/null
+++ b/games/tint/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tint: tint (tetris clone for the terminal)
+tint:
+tint: TINT Is Not Tetris
+tint:
+tint: As the title suggests, this is a clone of the original tetris game.
+tint:
+tint: The game is as close to the original as possible, but there are a
+tint: few differences. Nevertheless, it's probably the closest to the
+tint: original that you'll ever find in the UNIX world.
+tint:
+tint: Homepage: https://packages.debian.org/source/sid/tint
diff --git a/games/tint/tint.SlackBuild b/games/tint/tint.SlackBuild
new file mode 100644
index 0000000000..cd824dc768
--- /dev/null
+++ b/games/tint/tint.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for tint
+
+# Copyright 2022 Alexander Verbovetsky Moscow Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=tint
+VERSION=${VERSION:-0.07}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+make
+
+install -D -o root -g games -m 2755 -s tint $PKG/usr/bin/tint
+sed -i 's|/usr/share/doc/tint|/usr/doc/tint-*|' tint.6
+install -D -m 644 tint.6 $PKG/usr/man/man6/tint.6
+gzip -9 $PKG/usr/man/man6/tint.6
+install -D -m 644 debian/tint.png $PKG/usr/share/pixmaps/tint.png
+install -D -m 644 debian/tint.desktop $PKG/usr/share/applications/tint.desktop
+
+mkdir -p $PKG/var/games
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a NOTES debian/changelog $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/tint/tint.info b/games/tint/tint.info
new file mode 100644
index 0000000000..6290b10bd8
--- /dev/null
+++ b/games/tint/tint.info
@@ -0,0 +1,10 @@
+PRGNAM="tint"
+VERSION="0.07"
+HOMEPAGE="https://packages.debian.org/source/sid/tint"
+DOWNLOAD="https://deb.debian.org/debian/pool/main/t/tint/tint_0.07.tar.xz"
+MD5SUM="f6360a9d96f0821d2aee1095c91a9a1f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"