summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/tome-sx/README9
-rw-r--r--games/tome-sx/doinst.sh3
-rw-r--r--games/tome-sx/slack-desc19
-rw-r--r--games/tome-sx/tome-sx.SlackBuild102
-rw-r--r--games/tome-sx/tome-sx.info10
-rw-r--r--games/tome-sx/tome.sh4
6 files changed, 147 insertions, 0 deletions
diff --git a/games/tome-sx/README b/games/tome-sx/README
new file mode 100644
index 0000000000..c29a55a228
--- /dev/null
+++ b/games/tome-sx/README
@@ -0,0 +1,9 @@
+ToME-SX (short for "Sexy Edition") is a variant of the roguelike game
+ToME, based on version 2.3.5. The scope of this project is to add
+variety to the game, change some parts that (according to my personal
+opinion) need changing, and provide other people who are interested in
+the variant with the possibility of playing and enjoying it too. Have
+fun!
+
+You can install ToME-SX alongside other ToME 2 forks, but must back up,
+delete or save the save folder (~/.tome) between different games.
diff --git a/games/tome-sx/doinst.sh b/games/tome-sx/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/games/tome-sx/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/games/tome-sx/slack-desc b/games/tome-sx/slack-desc
new file mode 100644
index 0000000000..1a2d284b7d
--- /dev/null
+++ b/games/tome-sx/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tome-sx: tome-sx (Tales of Middle Earth Sexy Edition - fantasy adventure game)
+tome-sx:
+tome-sx: ToME-SX (short for "Sexy Edition") is a variant of the roguelike game
+tome-sx: ToME, based on version 2.3.5. The scope of this project is to add
+tome-sx: variety to the game, change some parts that (according to my personal
+tome-sx: opinion) need changing, and provide other people who are interested in
+tome-sx: the variant with the possibility of playing and enjoying it too.
+tome-sx:
+tome-sx: You can install ToME-SX alongside other ToME 2 forks, but will need to
+tome-sx: back up, move or delete the save folder (~/.tome) between different
+tome-sx: games.
diff --git a/games/tome-sx/tome-sx.SlackBuild b/games/tome-sx/tome-sx.SlackBuild
new file mode 100644
index 0000000000..abb6c4086b
--- /dev/null
+++ b/games/tome-sx/tome-sx.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/sh
+
+# Slackware build script for tome-sx
+
+# Copyright 2017, SlackBuilds.org Project, David Melik, Spokane, WA, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=tome-sx
+VERSION=${VERSION:-c1fe5a0ad25317a4bdf27ddba1522fd896389873}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCPRGNAM=ToME-SX
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCPRGNAM-$VERSION
+tar xvf $CWD/$SRCPRGNAM-$VERSION.tar.gz
+cd $SRCPRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cp src/makefile.std src/Makefile
+
+cd src
+ make COPTS="$SLKCFLAGS"
+ make install BINDIR=/usr/share/games/tome-sx LIBDIR=/usr/share/games/tome-sx/lib DESTDIR=$PKG
+cd ..
+
+install -m 0755 $CWD/tome.sh $PKG/usr/share/games/tome-sx/tome.sh
+mkdir -p $PKG/usr/games
+ln -fs /usr/share/games/tome-sx/tome.sh $PKG/usr/games/tome-sx
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG -name "delete.me" | xargs rm -f
+find $PKG -name ".cvsignore" | xargs rm -f
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ changes.txt copying.txt credits.txt LICENSE README.md lib/help \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/tome-sx/tome-sx.info b/games/tome-sx/tome-sx.info
new file mode 100644
index 0000000000..ca5a8d8c71
--- /dev/null
+++ b/games/tome-sx/tome-sx.info
@@ -0,0 +1,10 @@
+PRGNAM="tome-sx"
+VERSION="c1fe5a0ad25317a4bdf27ddba1522fd896389873"
+HOMEPAGE="https://github.com/AmyBSOD/ToME-SX"
+DOWNLOAD="https://github.com/AmyBSOD/ToME-SX/archive/c1fe5a0ad25317a4bdf27ddba1522fd896389873/ToME-SX-c1fe5a0ad25317a4bdf27ddba1522fd896389873.tar.gz"
+MD5SUM="79101bc283ed4f4af733800f824d3f4f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="David Melik"
+EMAIL="dchmelik@gmail.com"
diff --git a/games/tome-sx/tome.sh b/games/tome-sx/tome.sh
new file mode 100644
index 0000000000..232999ec7f
--- /dev/null
+++ b/games/tome-sx/tome.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+GAMES_TOME=/usr/share/games/tome-sx
+cd $GAMES_TOME
+exec ${GAMES_TOME}/tome "$@"