summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/apsw/README6
-rw-r--r--python/apsw/apsw.SlackBuild14
-rw-r--r--python/apsw/apsw.info8
3 files changed, 16 insertions, 12 deletions
diff --git a/python/apsw/README b/python/apsw/README
index c226b3fbcc..68a222356b 100644
--- a/python/apsw/README
+++ b/python/apsw/README
@@ -4,4 +4,8 @@ over SQLite attempting just to translate the complete SQLite API into Python.
The documentation has a section on the differences between APSW and pysqlite.
APSW supports CPython 2.3 onwards and CPython 3.1 onwards.
-Optionally Python 3 extension will be built if Python 3 is installed.
+Optional dependency: python3
+
+Note: To install python 3 set PYTHON3=yes.
+
+ # PYTHON3=yes ./apsw.SlackBuild
diff --git a/python/apsw/apsw.SlackBuild b/python/apsw/apsw.SlackBuild
index a09966c20b..724327c7c8 100644
--- a/python/apsw/apsw.SlackBuild
+++ b/python/apsw/apsw.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for apsw
-# Copyright 2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2013-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=apsw
-VERSION=${VERSION:-3.7.17_r1}
+VERSION=${VERSION:-3.13.0_r1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,15 +50,15 @@ unzip $CWD/$PRGNAM-${VERSION/_/-}.zip
cd $PRGNAM-${VERSION/_/-}
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build --enable-all-extensions
python setup.py install --root=$PKG --skip-build
-if $(python3 -c 'import os' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py build --enable-all-extensions
python3 setup.py install --root=$PKG --skip-build
fi
diff --git a/python/apsw/apsw.info b/python/apsw/apsw.info
index ef7784fd8a..32e1e610b9 100644
--- a/python/apsw/apsw.info
+++ b/python/apsw/apsw.info
@@ -1,8 +1,8 @@
PRGNAM="apsw"
-VERSION="3.7.17_r1"
-HOMEPAGE="http://code.google.com/p/apsw/"
-DOWNLOAD="http://apsw.googlecode.com/files/apsw-3.7.17-r1.zip"
-MD5SUM="5393765e7ef55def11dae08149133136"
+VERSION="3.13.0_r1"
+HOMEPAGE="https://github.com/rogerbinns/apsw"
+DOWNLOAD="https://github.com/rogerbinns/apsw/releases/download/3.13.0-r1/apsw-3.13.0-r1.zip"
+MD5SUM="54ecc75082848d440821007dc3806f39"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""