summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/bonnie++/Makefile.in_DESTDIR.diff34
-rw-r--r--system/bonnie++/README6
-rw-r--r--system/bonnie++/bonnie++.SlackBuild71
-rw-r--r--system/bonnie++/bonnie++.info8
-rw-r--r--system/bonnie++/slack-desc19
5 files changed, 138 insertions, 0 deletions
diff --git a/system/bonnie++/Makefile.in_DESTDIR.diff b/system/bonnie++/Makefile.in_DESTDIR.diff
new file mode 100644
index 0000000000..3b556e0b09
--- /dev/null
+++ b/system/bonnie++/Makefile.in_DESTDIR.diff
@@ -0,0 +1,34 @@
+Small patch to add DESTDIR support for easier packaging
+Use as you wish. --Robby Workman <rworkman@slackware.com>
+
+--- orig/Makefile.in 2008-02-20 13:53:26.319108308 -0600
++++ new/Makefile.in 2008-02-20 14:17:25.875109567 -0600
+@@ -4,6 +4,7 @@
+
+ SCRIPTS=bon_csv2html bon_csv2txt
+
++DESTDIR =
+ prefix=@prefix@
+ eprefix=@exec_prefix@
+ #MORE_WARNINGS=-Weffc++ -Wcast-align
+@@ -33,14 +34,14 @@
+ $(CXX) zcav.cpp -o zcav $(ZCAVOBJS) $(LFLAGS)
+
+ install-bin: $(EXES)
+- mkdir -p $(eprefix)/bin $(eprefix)/sbin
+- @INSTALL_PROGRAM@ @stripping@ $(EXES) $(eprefix)/sbin
+- @INSTALL_SCRIPT@ $(SCRIPTS) $(eprefix)/bin
++ mkdir -p $(DESTDIR)/$(eprefix)/bin $(DESTDIR)/$(eprefix)/sbin
++ @INSTALL_PROGRAM@ @stripping@ $(EXES) $(DESTDIR)/$(eprefix)/sbin
++ @INSTALL_SCRIPT@ $(SCRIPTS) $(DESTDIR)/$(eprefix)/bin
+
+ install: install-bin
+- mkdir -p @mandir@/man1 @mandir@/man8
+- @INSTALL_DATA@ $(MAN1) @mandir@/man1
+- @INSTALL_DATA@ $(MAN8) @mandir@/man8
++ mkdir -p $(DESTDIR)/@mandir@/man1 $(DESTDIR)/@mandir@/man8
++ @INSTALL_DATA@ $(MAN1) $(DESTDIR)/@mandir@/man1
++ @INSTALL_DATA@ $(MAN8) $(DESTDIR)/@mandir@/man8
+
+ %.o: %.cpp %.h bonnie.h port.h
+ $(CXX) -c $<
diff --git a/system/bonnie++/README b/system/bonnie++/README
new file mode 100644
index 0000000000..cce4ad527f
--- /dev/null
+++ b/system/bonnie++/README
@@ -0,0 +1,6 @@
+bonnie++ (a system benchmarking tool)
+
+This benchmark is named Bonnie++ - it is based on the Bonnie benchmark
+written by Tim Bray.
+Bonnie++ adds the facility to test more than 2G of storage on a on a
+32bit machine, and tests for file creat(), stat(), unlink() operations.
diff --git a/system/bonnie++/bonnie++.SlackBuild b/system/bonnie++/bonnie++.SlackBuild
new file mode 100644
index 0000000000..abe9305b73
--- /dev/null
+++ b/system/bonnie++/bonnie++.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for bonnie++
+# Written by Vincent Batts, vbatts@batts.mine.nu
+# Modified by Michiel van Wessem <michiel@slackbuils.org>
+
+PRGNAM=bonnie++
+VERSION=1.03c
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tgz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Small patch to Makefile.in to add DESTDIR support
+# Patch submitted to upstream --rworkman
+patch -p1 < $CWD/Makefile.in_DESTDIR.diff
+
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION
+
+make MORECFLAGS="$SLKCFLAGS"
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a readme.html credits.txt copyright.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/bonnie++/bonnie++.info b/system/bonnie++/bonnie++.info
new file mode 100644
index 0000000000..baaad31d46
--- /dev/null
+++ b/system/bonnie++/bonnie++.info
@@ -0,0 +1,8 @@
+PRGNAM="bonnie++"
+VERSION="1.03c"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+DOWNLOAD="http://www.coker.com.au/bonnie++/bonnie++-1.03c.tgz"
+MD5SUM="77a1ba78f37bdd7f024b67e1e36ad151"
+MAINTAINER="Vincent Batts"
+EMAIL="vbatts@batts.mine.nu"
+APPROVED="rworkman, Michiel"
diff --git a/system/bonnie++/slack-desc b/system/bonnie++/slack-desc
new file mode 100644
index 0000000000..0fb1c7b100
--- /dev/null
+++ b/system/bonnie++/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler----------------------------------------------------|
+bonnie++: bonnie++ (a system benchmarking tool)
+bonnie++:
+bonnie++: This benchmark is named Bonnie++ - it is based on the
+bonnie++: Bonnie benchmark written by Tim Bray.
+bonnie++: Bonnie++ adds the facility to test more than 2G of storage on a
+bonnie++: on a 32bit machine, and tests for file creat(), stat(), unlink()
+bonnie++: operations.
+bonnie++:
+bonnie++: Homepage: http://www.coker.com.au/bonnie++/
+bonnie++:
+bonnie++: