summaryrefslogtreecommitdiffstats
path: root/academic/bibus/bibus.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/bibus/bibus.SlackBuild')
-rw-r--r--academic/bibus/bibus.SlackBuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/academic/bibus/bibus.SlackBuild b/academic/bibus/bibus.SlackBuild
new file mode 100644
index 0000000000..82f1865117
--- /dev/null
+++ b/academic/bibus/bibus.SlackBuild
@@ -0,0 +1,66 @@
+#!/bin/sh
+
+# Slackware build script for bibus
+
+# Written by David Miller dave@frop.net
+# This script is released into the public domain
+
+# Modified by the SlackBuilds.org project
+
+PRGNAM=bibus
+VERSION=${VERSION:-1.4.3.2}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+SRC_VERSION=${SRC_VERSION:-1.4.3}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+mv $PRGNAM-$SRC_VERSION $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+#patch the makefile to install to PKGDIR
+patch Makefile < $CWD/Makefile.patch
+
+# Compile the application and install it into the $PKG directory
+make PKGDIR=$PKG \
+DESTDIR=/usr \
+mandir=/usr/man \
+sysconfdir=/etc \
+docdir=/usr/doc/$PRGNAM-$VERSION \
+oopath=/opt/openoffice.org3/program \
+ooure=/opt/openoffice.org3/basis-link/ure-link/lib \
+oobasis=/opt/openoffice.org3/basis-link/program
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a -r Docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz