summaryrefslogtreecommitdiffstats
path: root/accessibility/espeak/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/espeak/makefile.patch')
-rw-r--r--accessibility/espeak/makefile.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/accessibility/espeak/makefile.patch b/accessibility/espeak/makefile.patch
new file mode 100644
index 0000000000..ce3f2e7679
--- /dev/null
+++ b/accessibility/espeak/makefile.patch
@@ -0,0 +1,17 @@
+diff -Naur espeak-1.44.05-source/src/Makefile espeak-1.44.05-source.patched/src/Makefile
+--- espeak-1.44.05-source/src/Makefile 2010-08-13 17:35:09.000000000 -0400
++++ espeak-1.44.05-source.patched/src/Makefile 2010-12-26 19:31:55.000000000 -0500
+@@ -113,11 +113,9 @@
+ $(MKDIR) $(DESTDIR)$(INCDIR)
+ $(MKDIR) $(DESTDIR)$(DATADIR)
+ # Install espeak executable
+- $(INSTALL) -m 755 $(BIN2_NAME) $(DESTDIR)$(BINDIR)
++ $(INSTALL) -s -m 755 $(BIN2_NAME) $(DESTDIR)$(BINDIR)
+ # Install shared library
+- $(INSTALL) -m 755 $(LIB_NAME).$(LIBTAG) $(DESTDIR)$(LIBDIR)
+- # Install static library
+- $(INSTALL) -m 755 $(STATIC_LIB_NAME) $(DESTDIR)$(LIBDIR)
++ $(INSTALL) -s -m 755 $(LIB_NAME).$(LIBTAG) $(DESTDIR)$(LIBDIR)
+ $(LN_SF) $(LIB_NAME).$(LIBTAG) $(DESTDIR)$(LIBDIR)/$(LIB_NAME).$(LIB_VERSION)
+ $(LN_SF) $(LIB_NAME).$(LIB_VERSION) $(DESTDIR)$(LIBDIR)/$(LIB_NAME)
+ # Install development headers