summaryrefslogtreecommitdiffstats
path: root/audio/kanola/kanola.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/kanola/kanola.SlackBuild')
-rw-r--r--audio/kanola/kanola.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/audio/kanola/kanola.SlackBuild b/audio/kanola/kanola.SlackBuild
index 84d7c181c5..99151dc4dd 100644
--- a/audio/kanola/kanola.SlackBuild
+++ b/audio/kanola/kanola.SlackBuild
@@ -51,7 +51,11 @@ rm -rf $PRGNAM-$VERSION
tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
/usr/bin/python setup.py install --prefix $PKG/usr