summaryrefslogtreecommitdiffstats
path: root/games/openclonk/CMakeLists_boost.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/openclonk/CMakeLists_boost.patch')
-rw-r--r--games/openclonk/CMakeLists_boost.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/games/openclonk/CMakeLists_boost.patch b/games/openclonk/CMakeLists_boost.patch
new file mode 100644
index 0000000000..67ad837d6f
--- /dev/null
+++ b/games/openclonk/CMakeLists_boost.patch
@@ -0,0 +1,11 @@
+--- openclonk-5.4.1-src/CMakeLists.txt.original 2014-03-17 19:40:34.633722226 +0200
++++ openclonk-5.4.1-src/CMakeLists.txt 2014-03-17 19:41:33.135990847 +0200
+@@ -1425,7 +1425,7 @@
+ endif()
+
+ if(USE_BOOST_REGEX)
+- SET(Boost_USE_STATIC_LIBS ${USE_STATIC_BOOST})
++ SET(Boost_USE_STATIC_LIBS/usr/include/boost ${USE_STATIC_BOOST})
+ find_package(Boost 1.40.0 REQUIRED COMPONENTS regex)
+ # Disable automatic linking, we'll do it ourselves
+ add_definitions(-DBOOST_REGEX_NO_LIB)