summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/openclonk/CMakeLists_boost.patch11
-rw-r--r--games/openclonk/README3
-rw-r--r--games/openclonk/doinst.sh13
-rw-r--r--games/openclonk/openclonk.SlackBuild98
-rw-r--r--games/openclonk/openclonk.info10
-rw-r--r--games/openclonk/slack-desc19
6 files changed, 154 insertions, 0 deletions
diff --git a/games/openclonk/CMakeLists_boost.patch b/games/openclonk/CMakeLists_boost.patch
new file mode 100644
index 0000000000..67ad837d6f
--- /dev/null
+++ b/games/openclonk/CMakeLists_boost.patch
@@ -0,0 +1,11 @@
+--- openclonk-5.4.1-src/CMakeLists.txt.original 2014-03-17 19:40:34.633722226 +0200
++++ openclonk-5.4.1-src/CMakeLists.txt 2014-03-17 19:41:33.135990847 +0200
+@@ -1425,7 +1425,7 @@
+ endif()
+
+ if(USE_BOOST_REGEX)
+- SET(Boost_USE_STATIC_LIBS ${USE_STATIC_BOOST})
++ SET(Boost_USE_STATIC_LIBS/usr/include/boost ${USE_STATIC_BOOST})
+ find_package(Boost 1.40.0 REQUIRED COMPONENTS regex)
+ # Disable automatic linking, we'll do it ourselves
+ add_definitions(-DBOOST_REGEX_NO_LIB)
diff --git a/games/openclonk/README b/games/openclonk/README
new file mode 100644
index 0000000000..f169f53e9e
--- /dev/null
+++ b/games/openclonk/README
@@ -0,0 +1,3 @@
+OpenClonk is a free multiplayer action game in which you
+control clonks, small but witty and nimble humanoid beings.
+The game is mainly about mining, settling and fast-paced melees.
diff --git a/games/openclonk/doinst.sh b/games/openclonk/doinst.sh
new file mode 100644
index 0000000000..9424ce43ff
--- /dev/null
+++ b/games/openclonk/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/openclonk/openclonk.SlackBuild b/games/openclonk/openclonk.SlackBuild
new file mode 100644
index 0000000000..bcf3324139
--- /dev/null
+++ b/games/openclonk/openclonk.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for openclonk
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=openclonk
+VERSION=${VERSION:-5.4.1}
+SRCVER=$VERSION-src
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.bz2
+cd $PRGNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/CMakeLists_boost.patch
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING Credits.txt README Version.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/openclonk/openclonk.info b/games/openclonk/openclonk.info
new file mode 100644
index 0000000000..2d931d4068
--- /dev/null
+++ b/games/openclonk/openclonk.info
@@ -0,0 +1,10 @@
+PRGNAM="openclonk"
+VERSION="5.4.1"
+HOMEPAGE="http://www.openclonk.org/"
+DOWNLOAD="http://www.openclonk.org/builds/release/5.4.1/openclonk-5.4.1-src.tar.bz2"
+MD5SUM="551840061314eccfd7ae91e1f689167b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="freealut gtksourceview libupnp gtest"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/games/openclonk/slack-desc b/games/openclonk/slack-desc
new file mode 100644
index 0000000000..00893ec2d0
--- /dev/null
+++ b/games/openclonk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+openclonk: openclonk (action game)
+openclonk:
+openclonk: Free multiplayer action game in which you control clonks,
+openclonk: small but witty and nimble humanoid beings.
+openclonk: The game is mainly about mining, settling and fast-paced melees.
+openclonk:
+openclonk: Homepage: http://www.openclonk.org/
+openclonk:
+openclonk:
+openclonk:
+openclonk: