summaryrefslogtreecommitdiffstats
path: root/gis/Fiona
diff options
context:
space:
mode:
Diffstat (limited to 'gis/Fiona')
-rw-r--r--gis/Fiona/Fiona.SlackBuild27
-rw-r--r--gis/Fiona/Fiona.info8
-rw-r--r--gis/Fiona/README18
3 files changed, 31 insertions, 22 deletions
diff --git a/gis/Fiona/Fiona.SlackBuild b/gis/Fiona/Fiona.SlackBuild
index 5fa0ea09e3..b1cfbb9b20 100644
--- a/gis/Fiona/Fiona.SlackBuild
+++ b/gis/Fiona/Fiona.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for Fiona
-# Copyright 2013-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2013-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=Fiona
-VERSION=${VERSION:-1.8.7}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-1.8.20}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,10 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -87,4 +94,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/Fiona/Fiona.info b/gis/Fiona/Fiona.info
index 933c9868d4..e0f3d74acb 100644
--- a/gis/Fiona/Fiona.info
+++ b/gis/Fiona/Fiona.info
@@ -1,10 +1,10 @@
PRGNAM="Fiona"
-VERSION="1.8.7"
+VERSION="1.8.20"
HOMEPAGE="https://github.com/Toblerity/Fiona"
-DOWNLOAD="https://github.com/Toblerity/Fiona/archive/1.8.7/Fiona-1.8.7.tar.gz"
-MD5SUM="8f3fada8f1aa9cbc3b5844dfde716bb5"
+DOWNLOAD="https://github.com/Toblerity/Fiona/archive/1.8.20/Fiona-1.8.20.tar.gz"
+MD5SUM="186f39b90b8191c37745ceafacceda94"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="attrs gdal munch six"
+REQUIRES="gdal munch python3-attrs click-plugins cligj"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/Fiona/README b/gis/Fiona/README
index d079aa2700..ad7dc450bd 100644
--- a/gis/Fiona/README
+++ b/gis/Fiona/README
@@ -1,9 +1,11 @@
-Fiona provides uncomplicated Python interfaces to functions in OGR, the best
-open source C/C++ library for reading and writing geographic vector data.
+Fiona provides uncomplicated Python interfaces to functions in OGR,
+the best open source C/C++ library for reading and writing geographic
+vector data.
-Fiona is designed to be simple and dependable. It focuses on reading and
-writing data in standard Python IO style, and relies upon familiar Python types
-and protocols such as files, dictionaries, mappings, and iterators instead of
-classes specific to OGR. Fiona can read and write real-world data using
-multi-layered GIS formats and zipped virtual file systems and integrates
-readily with other Python GIS packages such as pyproj, Rtree and Shapely.
+Fiona is designed to be simple and dependable. It focuses on reading
+and writing data in standard Python IO style, and relies upon familiar
+Python types and protocols such as files, dictionaries, mappings, and
+iterators instead of classes specific to OGR. Fiona can read and write
+real-world data using multi-layered GIS formats and zipped virtual
+file systems and integrates readily with other Python GIS packages
+such as pyproj, Rtree and Shapely.