summaryrefslogtreecommitdiffstats
path: root/gis/gdal
diff options
context:
space:
mode:
Diffstat (limited to 'gis/gdal')
-rw-r--r--gis/gdal/README2
-rw-r--r--gis/gdal/gdal.SlackBuild8
2 files changed, 9 insertions, 1 deletions
diff --git a/gis/gdal/README b/gis/gdal/README
index 064469fb17..c959862f44 100644
--- a/gis/gdal/README
+++ b/gis/gdal/README
@@ -11,7 +11,7 @@ provides a similar capability for simple features vector data.
The following optional requirements are detected automatically:
cfitsio, freexl, hdf, hdf5, libkml, libwebp, netcdf,
- postgresql, xerces-c
+ postgresql, python3, xerces-c
To enable OpenCL GPU-accelerated performance, specify the option
OPENCL=yes (requires opencl-headers to build, and either nvidia-driver
diff --git a/gis/gdal/gdal.SlackBuild b/gis/gdal/gdal.SlackBuild
index 3e16baad69..be5ff762f8 100644
--- a/gis/gdal/gdal.SlackBuild
+++ b/gis/gdal/gdal.SlackBuild
@@ -143,6 +143,14 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ cd swig/python
+ rm -rf build
+ python3 setup.py build
+ python3 setup.py install --root=$PKG --prefix=/usr
+ cd - >/dev/null
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true