summaryrefslogtreecommitdiffstats
path: root/gis/gdal
diff options
context:
space:
mode:
Diffstat (limited to 'gis/gdal')
-rw-r--r--gis/gdal/README16
-rw-r--r--gis/gdal/gdal-python-install.patch10
-rw-r--r--gis/gdal/gdal.SlackBuild166
-rw-r--r--gis/gdal/gdal.info10
-rw-r--r--gis/gdal/slack-desc19
5 files changed, 221 insertions, 0 deletions
diff --git a/gis/gdal/README b/gis/gdal/README
new file mode 100644
index 0000000000..2d13ccb84d
--- /dev/null
+++ b/gis/gdal/README
@@ -0,0 +1,16 @@
+GDAL is a library for reading and writing raster geospatial data
+formats, and is released under an X/MIT style Open Source license by
+the Open Source Geospatial Foundation. As a library, it presents a
+single abstract data model to the calling application for all
+supported formats. It may also be built with a variety of useful
+command-line utilities for data translation and processing.
+
+The related OGR library (which is part of the GDAL source tree)
+provides a similar capability for simple features vector data.
+
+The following optional requirements are detected automatically:
+cfitsio, freexl, hdf5, libwebp, netcdf, postgresql, xerces-c
+
+To enable OpenCL GPU-accelerated performance, specify the option
+OPENCL=yes (requires opencl-headers to build, and either nvidia-driver
+or amd-app-sdk with suitable GPU hardware to run).
diff --git a/gis/gdal/gdal-python-install.patch b/gis/gdal/gdal-python-install.patch
new file mode 100644
index 0000000000..8ec414d37a
--- /dev/null
+++ b/gis/gdal/gdal-python-install.patch
@@ -0,0 +1,10 @@
+--- swig/python/GNUmakefile.orig 2010-04-24 01:22:07.000000000 +0200
++++ swig/python/GNUmakefile 2010-05-05 19:14:58.000000000 +0200
+@@ -72,5 +72,5 @@
+ ifeq ($(PY_HAVE_SETUPTOOLS),1)
+- $(PYTHON) setup.py install
++ $(PYTHON) setup.py install --root=$(DESTDIR)
+ else
+- $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix)
++ $(PYTHON) setup.py install --root=$(DESTDIR) --prefix=$(prefix)
+ endif
diff --git a/gis/gdal/gdal.SlackBuild b/gis/gdal/gdal.SlackBuild
new file mode 100644
index 0000000000..d48e6939e9
--- /dev/null
+++ b/gis/gdal/gdal.SlackBuild
@@ -0,0 +1,166 @@
+#!/bin/sh
+# Slackware build script for GDAL
+
+# Copyright 2009 Marco Cecchetti <mrc.ild@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Maintained by David Spencer <baildon.research@googlemail.com>
+
+PRGNAM=gdal
+VERSION=${VERSION:-1.10.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# OpenCL, webp, Spatialite and Grass support need special arrangements.
+# Everything else is handled automatically by configure.
+WITHLIST=""
+
+# Request OpenCL support:
+if [ ${OPENCL:-no} = "yes" ]; then
+ WITHLIST+=" --with-opencl"
+fi
+
+# Request webp support if it's installed:
+if pkg-config --exists libwebp; then
+ WITHLIST+=" --with-webp"
+fi
+
+# Spatialite support in gdal optionally has a circular dependency
+# via the postgis 'liblwgeom' library (postgis depends on gdal).
+# Here is an undocumented option to request Spatialite support,
+# if you promise to be careful :-)
+if pkg-config --exists spatialite; then
+ if [ ${SPATIALITE:-no} = "yes" ]; then
+ WITHLIST+=" --with-spatialite"
+ fi
+fi
+
+# Also, enabling Grass support in gdal introduces a circular dependency,
+# so here is another undocumented option.
+if pkg-config --exists grass; then
+ if [ ${GRASS:-no} = "yes" ]; then
+ WITHLIST+=" --with-grass=$(pkg-config --variable=prefix grass)"
+ fi
+fi
+
+# 12 bit JPEG support is handled by internal modified versions of libjpeg
+# and libtiff, but this can cause segfaults in other software linked against
+# the real libjpeg (eg. qgis calling qt). Enable JPEG12 only if you need it:
+if [ ${JPEG12:-no} = "yes" ]; then
+ WITHLIST+=" --with-jpeg=internal --with-libtiff=internal"
+else
+ WITHLIST+=" --with-jpeg=/usr/lib${LIBDIRSUFFIX} --with-libtiff=/usr/lib${LIBDIRSUFFIX}"
+fi
+
+# Thanks to the people at Arch for this:
+patch -p0 <$CWD/gdal-python-install.patch
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-static=no \
+ --with-threads \
+ --with-geos=yes \
+ --with-ogr=yes \
+ --with-libz=/usr/lib${LIBDIRSUFFIX} \
+ --with-liblzma \
+ --with-curl=/usr/bin/curl-config \
+ --without-grib \
+ --with-static-proj4 \
+ --with-mysql \
+ --with-python \
+ --with-poppler \
+ $WITHLIST \
+ --build=$ARCH-slackware-linux
+
+make -j1
+make install DESTDIR=$PKG
+
+# Kill erroneously installed .dox files
+rm $PKG/usr/bin/*.dox
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+make -f GNUmakefile -B man
+make install-man DESTDIR=$PKG
+gzip -9 $PKG/usr/man/man?/* || exit 1
+
+make -f GNUmakefile -B docs
+# --docdir is ignored :-(
+make install-docs DESTDIR=$PKG INST_DOCS=/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COMMITERS HOWTO-RELEASE LICENSE.TXT NEWS PROVENANCE.TXT VERSION \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/gdal/gdal.info b/gis/gdal/gdal.info
new file mode 100644
index 0000000000..092df41919
--- /dev/null
+++ b/gis/gdal/gdal.info
@@ -0,0 +1,10 @@
+PRGNAM="gdal"
+VERSION="1.10.1"
+HOMEPAGE="http://www.gdal.org/"
+DOWNLOAD="http://download.osgeo.org/gdal/1.10.1/gdal-1.10.1.tar.xz"
+MD5SUM="f354c614aea76e5630e4edbf06e5c292"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="geos proj %README%"
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/gis/gdal/slack-desc b/gis/gdal/slack-desc
new file mode 100644
index 0000000000..9bfe528cf2
--- /dev/null
+++ b/gis/gdal/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gdal: GDAL (translator library for raster geospatial data formats)
+gdal:
+gdal: The Geospatial Data Abstraction Library (GDAL) is a unifying
+gdal: C/C++ API for accessing raster geospatial data. The related OGR
+gdal: library (included with GDAL) provides a similar capability for vector
+gdal: data.
+gdal:
+gdal: Homepage: http://www.gdal.org
+gdal:
+gdal:
+gdal: