summaryrefslogtreecommitdiffstats
path: root/libraries/libflashsupport
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libflashsupport')
-rw-r--r--libraries/libflashsupport/README4
-rw-r--r--libraries/libflashsupport/change-features.patch17
-rw-r--r--libraries/libflashsupport/disable-pulse.patch32
-rw-r--r--libraries/libflashsupport/libflashsupport.SlackBuild110
-rw-r--r--libraries/libflashsupport/libflashsupport.info10
-rw-r--r--libraries/libflashsupport/slack-desc19
6 files changed, 0 insertions, 192 deletions
diff --git a/libraries/libflashsupport/README b/libraries/libflashsupport/README
deleted file mode 100644
index 0d08c5a011..0000000000
--- a/libraries/libflashsupport/README
+++ /dev/null
@@ -1,4 +0,0 @@
-libflashsupport is an additional library for Adobe Flash Player adding
-support for TLS, OSS and optionally PulseAudio.
-This library is known to solve problems about missing audio from Flash
-content, like videos embedded into web pages.
diff --git a/libraries/libflashsupport/change-features.patch b/libraries/libflashsupport/change-features.patch
deleted file mode 100644
index b99b0f132c..0000000000
--- a/libraries/libflashsupport/change-features.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -urp libflashsupport-ORIGINALE/flashsupport.c libflashsupport-MODIFICATO/flashsupport.c
---- libflashsupport-ORIGINALE/flashsupport.c 2008-07-02 11:43:50.000000000 +0200
-+++ libflashsupport-MODIFICATO/flashsupport.c 2008-07-02 11:46:33.000000000 +0200
-@@ -50,10 +50,10 @@
- //
-
- #define OPENSSL
--//#define GNUTLS
-+#define GNUTLS
- //#define ALSA
--//#define OSS
--#define V4L1
-+#define OSS
-+//#define V4L1
- #define PULSEAUDIO
-
- ////////////////////////////////////////////////////////////////////////////////////////////////////
diff --git a/libraries/libflashsupport/disable-pulse.patch b/libraries/libflashsupport/disable-pulse.patch
deleted file mode 100644
index f74dc225e8..0000000000
--- a/libraries/libflashsupport/disable-pulse.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -urp libflashsupport-MODIFICATO/configure.ac libflashsupport-MODIFICATO-NOPULSE/configure.ac
---- libflashsupport-MODIFICATO/configure.ac 2008-07-02 11:43:50.000000000 +0200
-+++ libflashsupport-MODIFICATO-NOPULSE/configure.ac 2008-07-02 11:48:52.000000000 +0200
-@@ -79,12 +79,12 @@ elif test -d ../pulseaudio ; then
- PULSE_CFLAGS='-I$(top_srcdir)/../pulseaudio/src'
- PULSE_LIBS='-L$(top_srcdir)/../pulseaudio/src/.libs -lpulse'
- echo "*** Found pulseaudio in ../pulseaudio, using that version ***"
--else
-- PKG_CHECK_MODULES(PULSE, [ libpulse >= 0.9.5 ])
-+#else
-+# PKG_CHECK_MODULES(PULSE, [ libpulse >= 0.9.5 ])
- fi
-
--AC_SUBST(PULSE_LIBS)
--AC_SUBST(PULSE_CFLAGS)
-+#AC_SUBST(PULSE_LIBS)
-+#AC_SUBST(PULSE_CFLAGS)
-
- PKG_CHECK_MODULES(LIBSSL, [ libssl ])
-
-diff -urp libflashsupport-MODIFICATO/flashsupport.c libflashsupport-MODIFICATO-NOPULSE/flashsupport.c
---- libflashsupport-MODIFICATO/flashsupport.c 2008-07-02 11:46:33.000000000 +0200
-+++ libflashsupport-MODIFICATO-NOPULSE/flashsupport.c 2008-07-02 11:48:21.000000000 +0200
-@@ -54,7 +54,7 @@
- //#define ALSA
- #define OSS
- //#define V4L1
--#define PULSEAUDIO
-+//#define PULSEAUDIO
-
- ////////////////////////////////////////////////////////////////////////////////////////////////////
- //
diff --git a/libraries/libflashsupport/libflashsupport.SlackBuild b/libraries/libflashsupport/libflashsupport.SlackBuild
deleted file mode 100644
index db9c900d52..0000000000
--- a/libraries/libflashsupport/libflashsupport.SlackBuild
+++ /dev/null
@@ -1,110 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for libflashsupport
-
-# Written by Mauro Giachero (mauro dot giachero at gmail dot com)
-
-# Copyright 2008 Mauro Giachero
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=libflashsupport
-VERSION=${VERSION:-20080328}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-# If you want PulseAudio support, start with PULSE=yes
-PULSE=${PULSE:-no}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Enable OSS and GNUTLS support
-patch -p1 <$CWD/change-features.patch
-
-# Disable PulseAudio
-[ "$PULSE" = "no" ] && patch -p1 <$CWD/disable-pulse.patch
-
-NOCONFIGURE=yes \
-./bootstrap.sh
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var
-
-make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-# The license is in the source file. Extract it.
-head -n $(grep -n -m1 "\*/" flashsupport.c |cut -d: -f1) flashsupport.c \
- >$PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libflashsupport/libflashsupport.info b/libraries/libflashsupport/libflashsupport.info
deleted file mode 100644
index d217e3c925..0000000000
--- a/libraries/libflashsupport/libflashsupport.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="libflashsupport"
-VERSION="20080328"
-HOMEPAGE="http://www.pulseaudio.org/wiki/FlashPlayer9Solution"
-DOWNLOAD="http://heanet.dl.sourceforge.net/project/salix-sbo/13.37/libflashsupport/libflashsupport-20080328.tar.gz"
-MD5SUM="1e6009d6ff98213e2932ebe6233db93f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Mauro Giachero"
-EMAIL="mauro dot giachero at gmail dot com"
diff --git a/libraries/libflashsupport/slack-desc b/libraries/libflashsupport/slack-desc
deleted file mode 100644
index 1dda8fd292..0000000000
--- a/libraries/libflashsupport/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-libflashsupport: libflashsupport (improve Adobe Flash Player platform support)
-libflashsupport:
-libflashsupport: libflashsupport is an experimental library adding support for TLS
-libflashsupport: and non-ALSA sound systems to Adobe Flash Player.
-libflashsupport:
-libflashsupport: Homepage: http://www.pulseaudio.org/wiki/FlashPlayer9Solution
-libflashsupport:
-libflashsupport:
-libflashsupport:
-libflashsupport:
-libflashsupport: