summaryrefslogtreecommitdiffstats
path: root/libraries/wxPython/wxPython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/wxPython/wxPython.SlackBuild')
-rw-r--r--libraries/wxPython/wxPython.SlackBuild115
1 files changed, 115 insertions, 0 deletions
diff --git a/libraries/wxPython/wxPython.SlackBuild b/libraries/wxPython/wxPython.SlackBuild
new file mode 100644
index 0000000000..96e4c07f23
--- /dev/null
+++ b/libraries/wxPython/wxPython.SlackBuild
@@ -0,0 +1,115 @@
+#!/bin/sh
+
+# Slackware build script for wxPython
+# Written by ppr:kut <hmwiesinger@gmx.at>
+
+# Copyright 2007 Heinz Wiesinger
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=wxPython
+VERSION=2.8.7.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-src-$VERSION
+tar xvf $CWD/$PRGNAM-src-$VERSION.tar.bz2
+cd $PRGNAM-src-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --with-sdl \
+ --with-opengl \
+ --enable-unicode
+
+make
+
+#Additional stuff needed by wxPython
+make -C contrib/src/gizmos
+make -C contrib/src/stc
+
+make install DESTDIR=$PKG
+make -C contrib/src/gizmos install DESTDIR=$PKG
+make -C contrib/src/stc install DESTDIR=$PKG
+
+cd wxPython
+ python setup.py \
+ WXPORT=gtk2 \
+ UNICODE=1 \
+ EP_ADD_OPTS=1 \
+ EP_FULL_VER=0 \
+ NO_SCRIPTS=1 \
+ WX_CONFIG="$TMP/$PRGNAM-src-$VERSION/wx-config --no_rpath" \
+ build_ext --rpath=/usr/lib \
+ build
+
+ python setup.py \
+ WXPORT=gtk2 \
+ UNICODE=1 \
+ EP_ADD_OPTS=1 \
+ EP_FULL_VER=0 \
+ NO_SCRIPTS=1 \
+ WX_CONFIG="$TMP/$PRGNAM-src-$VERSION/wx-config --prefix=$PKG/usr/bin/ --no_rpath" \
+ SYS_WX_CONFIG="wx-config --enable-unicode" \
+ build_ext --rpath=/usr/lib \
+ install --root=$PKG
+cd -
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/wxPython
+cp -a README.1st.txt docs* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a wxPython/docs/* $PKG/usr/doc/$PRGNAM-$VERSION/wxPython
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Remove unnecessary docs
+cd $PKG/usr/doc/$PRGNAM-$VERSION/docs
+ rm -rf cocoa latex mac metrowerks microwin msw palmos word
+cd -
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz