summaryrefslogtreecommitdiffstats
path: root/misc/fribid/fribid.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/fribid/fribid.SlackBuild')
-rw-r--r--misc/fribid/fribid.SlackBuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/misc/fribid/fribid.SlackBuild b/misc/fribid/fribid.SlackBuild
index 9537a426c1..b7d0fc7db4 100644
--- a/misc/fribid/fribid.SlackBuild
+++ b/misc/fribid/fribid.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=fribid
-VERSION=${VERSION:-0.3.0}
+VERSION=${VERSION:-1.0.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Should we build PKCS#11 smartcard support YES RUNTIME or nothing.
@@ -80,6 +80,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Deborkage thanks to Arch Linux
+sed -i \
+ -e 's/-DGTK_DISABLE_DEPRECATED=1//g' \
+ -e 's/-DGDK_DISABLE_DEPRECATED=1//g' \
+ -e 's/-DG_DISABLE_DEPRECATED=1//g' \
+ client/Makefile
+sed -i \
+ -e 's/strndup/strndup_/' \
+ plugin/pluginutil.c
+sed -i \
+ 's/_BSD_SOURCE/_DEFAULT_SOURCE/g' \
+ common/*.c plugin/*.c client/*.c
CFLAGS="$SLKCFLAGS" \
./configure \