summaryrefslogtreecommitdiffstats
path: root/misc/gprename/gprename-makefile-fixups.patch
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gprename/gprename-makefile-fixups.patch')
-rw-r--r--misc/gprename/gprename-makefile-fixups.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/misc/gprename/gprename-makefile-fixups.patch b/misc/gprename/gprename-makefile-fixups.patch
new file mode 100644
index 0000000000..cba26e8a96
--- /dev/null
+++ b/misc/gprename/gprename-makefile-fixups.patch
@@ -0,0 +1,49 @@
+diff -u -r gprename-20160905/Makefile gprename-20160905-patched/Makefile
+--- gprename-20160905/Makefile 2016-09-05 21:13:20.000000000 +0100
++++ gprename-20160905-patched/Makefile 2017-08-29 16:24:44.033333612 +0100
+@@ -45,8 +45,8 @@
+ # Create directories
+ install -d "$(DESTDIR)"
+ install -d "$(DESTDIR)/bin"
+- install -d "/usr/share"
+- install -d "/usr/share/icons"
++ install -d "$(DESTDIR)/share"
++ install -d "$(DESTDIR)/share/icons"
+ install -d "$(DESTDIR)/share/applications"
+ install -d "$(DESTDIR)/share/man"
+ install -d "$(DESTDIR)/share/man/man1"
+@@ -67,7 +67,7 @@
+ # Copy all files in the filesystem
+ install -m 755 build/gprename "$(DESTDIR)/bin/"
+ install -m 644 gprename-nautilus-actions.xml "$(DESTDIR)/share/applications/"
+- install -m 644 icon/gprename.png "/usr/share/icons/"
++ install -m 644 icon/gprename.png "$(DESTDIR)/share/icons/"
+ install -m 644 man/gprename.1 "$(DESTDIR)/share/man/man1/"
+ install -m 644 build/locale/ca.mo "$(DESTDIR)/share/locale/ca/LC_MESSAGES/gprename.mo"
+ install -m 644 build/locale/de.mo "$(DESTDIR)/share/locale/de/LC_MESSAGES/gprename.mo"
+@@ -82,13 +82,12 @@
+ install -m 644 build/locale/ru.mo "$(DESTDIR)/share/locale/ru/LC_MESSAGES/gprename.mo"
+ install -m 644 build/locale/sv.mo "$(DESTDIR)/share/locale/sv/LC_MESSAGES/gprename.mo"
+ install -m 644 build/locale/zh_CN.mo "$(DESTDIR)/share/locale/zh_CN/LC_MESSAGES/gprename.mo"
+- desktop-file-install bin/gprename.desktop
+- update-desktop-database
++ install -m 644 bin/gprename.desktop "$(DESTDIR)/share/applications/"
+ @echo "Installation completed."
+
+ uninstall: clean
+ rm -f "$(DESTDIR)/bin/gprename"
+- rm -f "/usr/share/applications/gprename.desktop"
++ rm -f "$(DESTDIR)/share/applications/gprename.desktop"
+ rm -f "$(DESTDIR)/share/applications/gprename-nautilus-actions.xml"
+ rm -f "$(DESTDIR)/share/man/man1/gprename.1"
+ rm -f "$(DESTDIR)/share/locale/ca/LC_MESSAGES/gprename.mo"
+@@ -104,8 +103,7 @@
+ rm -f "$(DESTDIR)/share/locale/ru/LC_MESSAGES/gprename.mo"
+ rm -f "$(DESTDIR)/share/locale/sv/LC_MESSAGES/gprename.mo"
+ rm -f "$(DESTDIR)/share/locale/zh_CN/LC_MESSAGES/gprename.mo"
+- rm -fr "/usr/share/icons/gprename"
+- update-desktop-database
++ rm -fr "$(DESTDIR)/share/icons/gprename"
+
+ clean:
+ rm -rf build