summaryrefslogtreecommitdiffstats
path: root/misc/megatunix
diff options
context:
space:
mode:
Diffstat (limited to 'misc/megatunix')
-rw-r--r--misc/megatunix/megatunix.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/misc/megatunix/megatunix.SlackBuild b/misc/megatunix/megatunix.SlackBuild
index ce2441d215..79b64dabe8 100644
--- a/misc/megatunix/megatunix.SlackBuild
+++ b/misc/megatunix/megatunix.SlackBuild
@@ -63,6 +63,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i \
+ -e 's/LIBGLADE_LIBS+="-Wl,--export-dynamic"/LIBGLADE_LIBS+=" -Wl,--export-dynamic"/' \
+ configure.ac
+autoreconf -vif
+
# Starting with glib 2.32 it is now mandatory to
# include glib.h instead of individual headers.
patch -p1 -i $CWD/glib-single-include.patch