summaryrefslogtreecommitdiffstats
path: root/misc/tegaki-zinnia-japanese
diff options
context:
space:
mode:
Diffstat (limited to 'misc/tegaki-zinnia-japanese')
-rw-r--r--misc/tegaki-zinnia-japanese/README3
-rw-r--r--misc/tegaki-zinnia-japanese/slack-desc19
-rw-r--r--misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.SlackBuild87
-rw-r--r--misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.info10
4 files changed, 119 insertions, 0 deletions
diff --git a/misc/tegaki-zinnia-japanese/README b/misc/tegaki-zinnia-japanese/README
new file mode 100644
index 0000000000..676c61fa05
--- /dev/null
+++ b/misc/tegaki-zinnia-japanese/README
@@ -0,0 +1,3 @@
+tegaki-zinnia-japanese is a data model for Zinnia.
+Zinnia is a simple, customizable and portable online hand recognition
+system based on Support Vector Machines.
diff --git a/misc/tegaki-zinnia-japanese/slack-desc b/misc/tegaki-zinnia-japanese/slack-desc
new file mode 100644
index 0000000000..69fa1d5db3
--- /dev/null
+++ b/misc/tegaki-zinnia-japanese/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tegaki-zinnia-japanese: tegaki-zinnia-japanese (Japanese handwriting model for Zinnia)
+tegaki-zinnia-japanese:
+tegaki-zinnia-japanese: tegaki-zinnia-japanese is a data model for Zinnia.
+tegaki-zinnia-japanese: Zinnia is a simple, customizable and portable online hand recognition
+tegaki-zinnia-japanese: system based on Support Vector Machines.
+tegaki-zinnia-japanese:
+tegaki-zinnia-japanese: Homepage: http://www.tegaki.org
+tegaki-zinnia-japanese:
+tegaki-zinnia-japanese:
+tegaki-zinnia-japanese:
+tegaki-zinnia-japanese:
diff --git a/misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.SlackBuild b/misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.SlackBuild
new file mode 100644
index 0000000000..5207ceb627
--- /dev/null
+++ b/misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for tegaki-zinnia-japanese
+# Issued under The MIT License (MIT)
+#
+# Copyright 2015 Kuro_CODE25
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+PRGNAM=tegaki-zinnia-japanese
+VERSION=${VERSION:-0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+#prepare
+sed -i 's|installpath=/usr/local/|installpath=/tmp/SBo/package-tegaki-zinnia-japanese/usr/|g' \
+ ./Makefile
+make
+make install DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING VERSION README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.info b/misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.info
new file mode 100644
index 0000000000..2f1e61b639
--- /dev/null
+++ b/misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.info
@@ -0,0 +1,10 @@
+PRGNAM="tegaki-zinnia-japanese"
+VERSION="0.3"
+HOMEPAGE="http://www.tegaki.org"
+DOWNLOAD="http://www.tegaki.org/releases/0.3/models/tegaki-zinnia-japanese-0.3.zip"
+MD5SUM="19c2ed9e770c23016f788b06ade41f95"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Kuro_CODE25"
+EMAIL="kuro.code25@gmail.com"