summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
Diffstat (limited to 'misc')
-rw-r--r--misc/protobuf3/README3
-rw-r--r--misc/protobuf3/protobuf3.SlackBuild9
-rw-r--r--misc/protobuf3/protobuf3.info6
3 files changed, 12 insertions, 6 deletions
diff --git a/misc/protobuf3/README b/misc/protobuf3/README
index 3c70ca0ab0..40fd496a9d 100644
--- a/misc/protobuf3/README
+++ b/misc/protobuf3/README
@@ -25,4 +25,5 @@ NOTE:
continue to support protobuf version 2.
* Protobuf3 enforces strict UTF-8 checking.
Parsing will fail if a string field contains non UTF-8 data.
-* This SlackBuild installs the Python bindings by default.
+* This SlackBuild installs the Python2 bindings by default.
+ Python3 bindings will be installed if Python3 is installed.
diff --git a/misc/protobuf3/protobuf3.SlackBuild b/misc/protobuf3/protobuf3.SlackBuild
index 36529c0d01..163ef957f4 100644
--- a/misc/protobuf3/protobuf3.SlackBuild
+++ b/misc/protobuf3/protobuf3.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for protobuf3
-# Copyright 2017 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2017-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=protobuf3
-VERSION=${VERSION:-3.3.2}
+VERSION=${VERSION:-3.5.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -101,6 +101,11 @@ make install DESTDIR=$PKG
# Install the python bindings
cd python ; python setup.py install --root=$PKG ; cd ..
+# Add Python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ cd python ; python3 setup.py install --root=$PKG ; cd ..
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/misc/protobuf3/protobuf3.info b/misc/protobuf3/protobuf3.info
index ecd35737fb..399cb32bd7 100644
--- a/misc/protobuf3/protobuf3.info
+++ b/misc/protobuf3/protobuf3.info
@@ -1,9 +1,9 @@
PRGNAM="protobuf3"
-VERSION="3.3.2"
+VERSION="3.5.1.1"
HOMEPAGE="https://github.com/google/protobuf"
-DOWNLOAD="https://github.com/google/protobuf/archive/v3.3.2/protobuf-3.3.2.tar.gz \
+DOWNLOAD="https://github.com/google/protobuf/archive/v3.5.1.1/protobuf-3.5.1.1.tar.gz \
https://github.com/google/googletest/archive/release-1.8.0/googletest-release-1.8.0.tar.gz"
-MD5SUM="ef2a6a6bb3b92d8fa8d71e3cef741f2f \
+MD5SUM="5005003ae6b94773c4bbca87a644b131 \
16877098823401d1bf2ed7891d7dce36"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""