summaryrefslogtreecommitdiffstats
path: root/multimedia/ucview/ucview.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/ucview/ucview.SlackBuild')
-rw-r--r--multimedia/ucview/ucview.SlackBuild48
1 files changed, 19 insertions, 29 deletions
diff --git a/multimedia/ucview/ucview.SlackBuild b/multimedia/ucview/ucview.SlackBuild
index 3d953744d7..2df5c27f43 100644
--- a/multimedia/ucview/ucview.SlackBuild
+++ b/multimedia/ucview/ucview.SlackBuild
@@ -23,7 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ucview
-VERSION=${VERSION:-0.33}
+VERSION=${VERSION:-20150221}
+SRCVERSION=${SRCVERSION:-29bd93aeef0573c58c9aee665dc43fdfd1f77a1f}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,9 +60,17 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$SRCVERSION
+
+# The upstream tarball will be named differently, depending on the
+# file being downloaded manually (web browser) or with wget.
+if [ -e $CWD/$SRCVERSION.tar.gz ]; then
+ tar xvzf $CWD/$SRCVERSION.tar.gz
+else
+ tar xvzf $CWD/$PRGNAM-$SRCVERSION.tar.gz
+fi
+
+cd $PRGNAM-$SRCVERSION/trunk/$PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,35 +78,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-PTC=$CWD/patches
-
-## Fixing a few bugs. For more information than those provided below please
-## see the related file: 'patches/patches.README'.
-
-# 1) Fix bug caused by a deprecated page size setting of 'GtkSpinButton' in
-# function 'gtk_adjustment_new'. The bug triggers error messages when video
-# encoding is switched to OGG/Theora (i.e. one message for each related spin
-# button).
-patch src/settings_dialog.c < $PTC/ucview-0.33-deprecated_Gtk_setting.patch
-
-# 2) Fix bug caused by UCView not being able to create a directory for plugins
-# when the parent directory '.ucview' is not already there (e.g. when the box
-# in the 'Select device' window was not checked at least once).
-patch src/plugin_loader.c < $PTC/ucview-0.33-plugins_mkdir_parents.patch
-
-# 3) Fix bug caused by the path for captured video files being set by default
-# to NULL, thus not allowing to save anything unless it is set explicitly.
-patch src/callbacks.c < $PTC/ucview-0.33-default_video_path.patch
-
-# 4) Something similar to 3) happens to the path for image files as well.
-patch src/ucview-window.c < $PTC/ucview-0.33-default_image_path.patch
-
PRGMAN=$PKG/usr/man/man1
PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+# Remove reference to non existent 'm4' directory.
+sed -i -e "s~^ACLOCAL_AMFLAGS.*$~~" Makefile.am
+
+autoreconf --force --install
+intltoolize --force
+
CFLAGS="$SLKCFLAGS" \
-# Compiler fails without this library:
-LIBS="-lgmodule-2.0" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \