summaryrefslogtreecommitdiffstats
path: root/network/dnscrypt-wrapper/dnscrypt-wrapper.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/dnscrypt-wrapper/dnscrypt-wrapper.SlackBuild')
-rw-r--r--network/dnscrypt-wrapper/dnscrypt-wrapper.SlackBuild18
1 files changed, 2 insertions, 16 deletions
diff --git a/network/dnscrypt-wrapper/dnscrypt-wrapper.SlackBuild b/network/dnscrypt-wrapper/dnscrypt-wrapper.SlackBuild
index a22ea80be0..4c7a9a29de 100644
--- a/network/dnscrypt-wrapper/dnscrypt-wrapper.SlackBuild
+++ b/network/dnscrypt-wrapper/dnscrypt-wrapper.SlackBuild
@@ -26,7 +26,7 @@
# suggestion.
PRGNAM=dnscrypt-wrapper
-VERSION=${VERSION:-0.1.17}
+VERSION=${VERSION:-0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,27 +57,17 @@ else
LIBDIRSUFFIX=""
fi
-# argparse is a git submodule required for building...
-ARGPARSEVERSION=${ARGPARSEVERSION:-e1277bf1e3f47663fad54f84ca723db7688630d4}
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION argparse-$ARGPARSEVERSION
+rm -rf $PRGNAM-$VERSION
if [ -e $CWD/v$VERSION.tar.gz ]; then
tar xvf $CWD/v$VERSION.tar.gz
else
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
fi
-if [ -e $CWD/$ARGPARSEVERSION.tar.gz ]; then
- tar xvf $CWD/$ARGPARSEVERSION.tar.gz
-else
- tar xvf $CWD/argparse-$ARGPARSEVERSION.tar.gz
-fi
-# argparse source is expected in dnscrypt source...
-mv argparse-$ARGPARSEVERSION/* $PRGNAM-$VERSION/argparse/
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -86,10 +76,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Patch out git submodule init. Already have argparse anyway, and this is not
-# a git repo (so it would fail)...
-patch -p0 < $CWD/Makefile.patch
-
make configure
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \