summaryrefslogtreecommitdiffstats
path: root/network/packETH/packETH.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/packETH/packETH.SlackBuild')
-rw-r--r--network/packETH/packETH.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/network/packETH/packETH.SlackBuild b/network/packETH/packETH.SlackBuild
index d6e1108b55..6712e90597 100644
--- a/network/packETH/packETH.SlackBuild
+++ b/network/packETH/packETH.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=packETH
-VERSION=${VERSION:-1.8.1}
+VERSION=${VERSION:-1.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,9 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-cp CHANGELOG ChangeLog
sed -i 's/^LIBS=/LIBS+=/' Makefile.am
-autoreconf
+autoreconf -f -i
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -86,6 +85,11 @@ CFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
+cd cli
+make
+cp packETHcli $PKG/usr/bin/
+cd ..
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true