summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
Diffstat (limited to 'network')
-rw-r--r--network/sftp-cloudfs/README13
-rw-r--r--network/sftp-cloudfs/doinst.sh14
-rw-r--r--network/sftp-cloudfs/sftp-cloudfs.SlackBuild89
-rw-r--r--network/sftp-cloudfs/sftp-cloudfs.info10
-rw-r--r--network/sftp-cloudfs/slack-desc19
5 files changed, 145 insertions, 0 deletions
diff --git a/network/sftp-cloudfs/README b/network/sftp-cloudfs/README
new file mode 100644
index 0000000000..c42ac6eaab
--- /dev/null
+++ b/network/sftp-cloudfs/README
@@ -0,0 +1,13 @@
+This is a SFTP (Secure File Transfer Protocol) interface to OpenStack
+Object Storage, providing a service that acts as a proxy between a
+SFTP client and a storage service.
+
+The username/password pair used to open the SFTP session is validated
+using the authentication service of the files/storage service to get
+an authentication token.
+
+The communication between the client and the SFTP daemon is encrypted
+all the time, and the SFTP service supports HTTPS communication with
+the remote files/storage service.
+
+There's limited SCP support since 0.10.
diff --git a/network/sftp-cloudfs/doinst.sh b/network/sftp-cloudfs/doinst.sh
new file mode 100644
index 0000000000..ba4a70f16f
--- /dev/null
+++ b/network/sftp-cloudfs/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/sftpcloudfs.conf.new
diff --git a/network/sftp-cloudfs/sftp-cloudfs.SlackBuild b/network/sftp-cloudfs/sftp-cloudfs.SlackBuild
new file mode 100644
index 0000000000..1ebb31b016
--- /dev/null
+++ b/network/sftp-cloudfs/sftp-cloudfs.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for "sftp-cloudfs".
+
+# Copyright 2015 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=sftp-cloudfs
+SRCNAM=sftpcloudfs
+VERSION=${VERSION:-0.18}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$VERSION.tar.gz || tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+mkdir -p $PKG/etc
+install -m 0644 $SRCNAM.conf.example $PKG/etc/$SRCNAM.conf.new
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING ChangeLog QuickStart.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/sftp-cloudfs/sftp-cloudfs.info b/network/sftp-cloudfs/sftp-cloudfs.info
new file mode 100644
index 0000000000..9dcd0de1aa
--- /dev/null
+++ b/network/sftp-cloudfs/sftp-cloudfs.info
@@ -0,0 +1,10 @@
+PRGNAM="sftp-cloudfs"
+VERSION="0.18"
+HOMEPAGE="https://github.com/Memset/sftpcloudfs/"
+DOWNLOAD="https://github.com/Memset/sftpcloudfs/archive/0.18.tar.gz"
+MD5SUM="dfd746a86ed4b9712c1cb3de418813b3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="ftp-cloudfs paramiko"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"
diff --git a/network/sftp-cloudfs/slack-desc b/network/sftp-cloudfs/slack-desc
new file mode 100644
index 0000000000..05ae8897b0
--- /dev/null
+++ b/network/sftp-cloudfs/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+sftp-cloudfs: sftp-cloudfs (SFTP interface to OpenStack Object Storage (Swift))
+sftp-cloudfs:
+sftp-cloudfs: This is a SFTP (Secure File Transfer Protocol) interface to OpenStack
+sftp-cloudfs: Object Storage, providing a service that acts as a proxy between a
+sftp-cloudfs: SFTP client and a storage service.
+sftp-cloudfs:
+sftp-cloudfs: Homepage: https://github.com/Memset/sftpcloudfs/
+sftp-cloudfs:
+sftp-cloudfs:
+sftp-cloudfs:
+sftp-cloudfs: