summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
Diffstat (limited to 'network')
-rw-r--r--network/weathercli/weathercli.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/network/weathercli/weathercli.SlackBuild b/network/weathercli/weathercli.SlackBuild
index 06e772c35c..2073cb7c1c 100644
--- a/network/weathercli/weathercli.SlackBuild
+++ b/network/weathercli/weathercli.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for weathercli
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=weathercli
VERSION=${VERSION:-2.3.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,6 +70,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# rename executable
+sed -i "s/bin\/weather/bin\/weathercli/" setup.py
+mv bin/weather bin/weathercli
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \