summaryrefslogtreecommitdiffstats
path: root/office/htmldoc/htmldoc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/htmldoc/htmldoc.SlackBuild')
-rw-r--r--office/htmldoc/htmldoc.SlackBuild87
1 files changed, 51 insertions, 36 deletions
diff --git a/office/htmldoc/htmldoc.SlackBuild b/office/htmldoc/htmldoc.SlackBuild
index f88d47c057..b66ecd1b33 100644
--- a/office/htmldoc/htmldoc.SlackBuild
+++ b/office/htmldoc/htmldoc.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for htmldoc
# Copyright 2009-2014 LukenShiro, Italy
+# Copyright 2023 Matteo Bernardini, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,6 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230630 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - use BUILDROOT instead of --prefix=$PKG/usr, avoids compiling the
+# $PKG path into the binary.
+# - fix 32x32 icon (it was 31x31).
+# - don't include empty icon dirs in the package.
+# - make .desktop file validate.
+
# Thanks to Gentoo htmldoc's .ebuild maintainer for hints about configure's
# workaround, and for a patch to fix CVE-2009-3050.
#
@@ -29,11 +37,23 @@
# Feb 01 2017: Alfredo
# Update script for html-1.8.29, fix the problem with /usr/share/htmldoc/data
# not being copied into the package
+#
+#
+# May 01 2020: organixpear
+# Update script for htmldoc-1.9.8
+# This was a needed update as htmldoc-1.8.29 was 3 years out of date
+# and the build would fail on recent versions (current) of Slackware.
+# gnutls support was also found to be working in htmldoc-1.9.8 so
+# support was added. Misc updates and cleanups to install commands.
+#
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=htmldoc
-VERSION=${VERSION:-1.8.29}
+VERSION=${VERSION:-1.9.16}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -43,12 +63,19 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCFILES="CHANGES.txt README.txt COMPILE.txt COPYING.txt htmldoc.readme"
+DOCFILES="CHANGES.md README.md COPYING"
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
@@ -70,7 +97,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION-source.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION-source.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -80,12 +107,12 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# workaround to avoid /usr/share/doc/htmldoc's use for help function
-sed -r -i 's|^#define DOCUMENTATION "$prefix/share/doc/htmldoc"|\
- #define DOCUMENTATION "$prefix/doc/htmldoc-$VERSION"|g' ./configure
+sed -i -e "s|\$datadir/doc/htmldoc|/usr/doc/htmldoc-$VERSION/html|" \
+ -e "s|^docdir=.*|docdir=/usr/doc/$PRGNAM-$VERSION|" ./configure || exit 1
# to avoid an invalid implicit declaration of function (for 'CUPS_SRAND' and 'CUPS_RAND')
-sed -r -i 's|CUPS_SRAND|srand|g' htmldoc/http.c
-sed -r -i 's|CUPS_RAND|rand|g' htmldoc/http.c
+sed -r -i 's|CUPS_SRAND|srand|g' htmldoc/http.c || exit 1
+sed -r -i 's|CUPS_RAND|rand|g' htmldoc/http.c || exit 1
# --mandir seems to be ignored; --docdir doesn't exist
# internal jpeg/png/zlib libs disabled (using system ones)
@@ -93,57 +120,45 @@ sed -r -i 's|CUPS_RAND|rand|g' htmldoc/http.c
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
- --prefix=$PKG/usr \
- --libdir=$PKG/usr/lib${LIBDIRSUFFIX} \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--enable-ssl \
--with-gui \
- --disable-localjpeg \
- --disable-localzlib \
- --disable-localpng \
- --disable-gnutls \
+ --enable-gnutls \
--build=$ARCH-slackware-linux
-# workaround to avoid /usr/share/doc/htmldoc's use for doc installation
-sed -r -i 's|\$(datadir)/doc/htmldoc|\$(prefix)/doc/htmldoc-$VERSION|g' \
- doc/Makefile
-
# 'make all' also does install (DESTDIR not supported)
-make all
+# 20230630 bkw: DESTDIR is spelled BUILDROOT, here.
+make all BUILDROOT=$PKG
# Copy some files who are not automatically installed (main binary, .desktop, icons, etc..)
mkdir -p $PKG/usr/bin
install -m 755 htmldoc/$PRGNAM $PKG/usr/bin
-mkdir -p $PKG/usr/man/man1
-cp -a doc/$PRGNAM.1 $PKG/usr/man/man1
mkdir -p $PKG/usr/share/applications
cp -a desktop/$PRGNAM.desktop $PKG/usr/share/applications
-mkdir -p $PKG/usr/share/mimelnk/application
-cp -a desktop/vnd.htmldoc-book.desktop $PKG/usr/share/mimelnk/application
mkdir -p $PKG/usr/share/mime/packages
cp -a desktop/htmldoc.xml $PKG/usr/share/mime/packages
-mkdir -p $PKG/usr/share/icons/hicolor/{16x16,24x24,32x32,48x48,64x64,96x96,128x128}/apps/
-cp -a desktop/htmldoc-16.png $PKG/usr/share/icons/hicolor/16x16/apps/$PRGNAM.png
-cp -a desktop/htmldoc-24.png $PKG/usr/share/icons/hicolor/24x24/apps/$PRGNAM.png
-cp -a desktop/htmldoc-32.png $PKG/usr/share/icons/hicolor/32x32/apps/$PRGNAM.png
-cp -a desktop/htmldoc-48.png $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
-cp -a desktop/htmldoc-64.png $PKG/usr/share/icons/hicolor/64x64/apps/$PRGNAM.png
-cp -a desktop/htmldoc-96.png $PKG/usr/share/icons/hicolor/96x96/apps/$PRGNAM.png
+mkdir -p $PKG/usr/share/icons/hicolor/{32x32,128x128,256x256}/apps/
+convert desktop/htmldoc-32.png -geometry 32x32 $PKG/usr/share/icons/hicolor/32x32/apps/$PRGNAM.png
cp -a desktop/htmldoc-128.png $PKG/usr/share/icons/hicolor/128x128/apps/$PRGNAM.png
+cp -a desktop/htmldoc-256.png $PKG/usr/share/icons/hicolor/256x256/apps/$PRGNAM.png
mkdir -p $PKG/usr/share/htmldoc/
cp -a fonts $PKG/usr/share/htmldoc/
cp -a data $PKG/usr/share/htmldoc/
+mkdir -p $PKG/usr/man/man1
+gzip -c9 doc/htmldoc.man > $PKG/usr/man/man1/htmldoc.1.gz
+sed -i '/^Categories/s,Application;,,' $PKG/usr/share/applications/*.desktop
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
# Just in case ..
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
-cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
-
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
+cp -a $DOCFILES doc/$PRGNAM.{epub,html,pdf,ps} $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/*.{html,png} $PKG/usr/doc/$PRGNAM-$VERSION/html
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -151,4 +166,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE