summaryrefslogtreecommitdiffstats
path: root/office/hyphen-id/hyphen-id.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/hyphen-id/hyphen-id.SlackBuild')
-rw-r--r--office/hyphen-id/hyphen-id.SlackBuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/office/hyphen-id/hyphen-id.SlackBuild b/office/hyphen-id/hyphen-id.SlackBuild
new file mode 100644
index 0000000000..42a27e31fd
--- /dev/null
+++ b/office/hyphen-id/hyphen-id.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for hyphen-id
+
+# Copyright 2017 Ali Ahmadi <idnux09@gmail.com>
+# # All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Based on the Arch PKGBUILD
+
+PRGNAM=hyphen-id
+VERSION=${VERSION:-2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+ARCH="noarch"
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir -p $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+
+bsdtar -xf $CWD/id_id.oxt
+
+# Putting everything in proper place
+install -dm755 $PKG/usr/share/hyphen
+install -m644 hyph_id_ID.dic $PKG/usr/share/hyphen
+
+# myspell symlinks
+install -dm755 $PKG/usr/share/myspell/dicts
+pushd $PKG/usr/share/myspell/dicts
+ for file in $PKG/usr/share/hyphen/*; do
+ ln -sv ../../hyphen/$(basename $file) .
+ done
+popd
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -m644 info/long-description.txt $PKG/usr/doc/$PRGNAM-$VERSION/README.txt
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}