summaryrefslogtreecommitdiffstats
path: root/python/MarkupSafe/MarkupSafe.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/MarkupSafe/MarkupSafe.SlackBuild')
-rw-r--r--python/MarkupSafe/MarkupSafe.SlackBuild31
1 files changed, 26 insertions, 5 deletions
diff --git a/python/MarkupSafe/MarkupSafe.SlackBuild b/python/MarkupSafe/MarkupSafe.SlackBuild
index c976072c8b..5886323cbc 100644
--- a/python/MarkupSafe/MarkupSafe.SlackBuild
+++ b/python/MarkupSafe/MarkupSafe.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for MarkupSafe
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2010-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=MarkupSafe
-VERSION=${VERSION:-0.18}
+VERSION=${VERSION:-0.23}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,13 +68,16 @@ find -L . \
CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG --no-compile
+if $(python3 -c 'import setuptools' 2>/dev/null); then
+ CFLAGS="$SLKCFLAGS" \
+ python3 setup.py install --root=$PKG --no-compile
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS LICENSE PKG-INFO README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install