summaryrefslogtreecommitdiffstats
path: root/python/PyPDF2
diff options
context:
space:
mode:
Diffstat (limited to 'python/PyPDF2')
-rw-r--r--python/PyPDF2/PyPDF2.SlackBuild39
-rw-r--r--python/PyPDF2/PyPDF2.info10
-rw-r--r--python/PyPDF2/README11
-rw-r--r--python/PyPDF2/slack-desc2
4 files changed, 30 insertions, 32 deletions
diff --git a/python/PyPDF2/PyPDF2.SlackBuild b/python/PyPDF2/PyPDF2.SlackBuild
index 810500e285..e7fd2ff9c7 100644
--- a/python/PyPDF2/PyPDF2.SlackBuild
+++ b/python/PyPDF2/PyPDF2.SlackBuild
@@ -1,9 +1,10 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for PyPDF2.
# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
# Copyright 2015-2017 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2023 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +24,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=PyPDF2
VERSION=${VERSION:-1.26.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +40,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -44,28 +52,15 @@ OUTPUT=${OUTPUT:-/tmp}
DOCS="CHANGELOG LICENSE README.md"
SAMPLES="Scripts/ Sample_Code/ Resources/"
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
+rm -rvf $PKG
+mkdir -pv $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+rm -rvf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -73,7 +68,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --prefix=/usr --root=$PKG --optimize=1
+python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -81,9 +77,10 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -ar $DOCS $SAMPLES $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/PyPDF2/PyPDF2.info b/python/PyPDF2/PyPDF2.info
index 7350b3e4f9..92ed3e93d9 100644
--- a/python/PyPDF2/PyPDF2.info
+++ b/python/PyPDF2/PyPDF2.info
@@ -1,10 +1,10 @@
PRGNAM="PyPDF2"
VERSION="1.26.0"
-HOMEPAGE="https://mstamy2.github.io/PyPDF2/"
-DOWNLOAD="https://github.com/mstamy2/PyPDF2/archive/1.26.0/PyPDF2-1.26.0.tar.gz"
-MD5SUM="3959e3a15606e4b6c0405487cefb4e21"
+HOMEPAGE="https://pypi.org/project/PyPDF2/"
+DOWNLOAD="https://pypi.io/packages/source/P/PyPDF2/PyPDF2-1.26.0.tar.gz"
+MD5SUM="2301acc0ecbab0633d4c9b883d50ee5e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Brenton Earl"
-EMAIL="brent@exitstatusone.com"
+MAINTAINER="Vijay Marcel"
+EMAIL="vijaymarcel@outlook.com"
diff --git a/python/PyPDF2/README b/python/PyPDF2/README
index 80f9b05996..ac1b70eb18 100644
--- a/python/PyPDF2/README
+++ b/python/PyPDF2/README
@@ -6,9 +6,10 @@ A Pure-Python library built as a PDF toolkit. It is capable of:
* merging multiple pages into a single page
* encrypting and decrypting PDF files
-By being Pure-Python, it should run on any Python platform without any
-dependencies on external libraries. It can also work entirely on StringIO
-objects rather than file streams, allowing for PDF manipulation in memory. It is
-therefore a useful tool for websites that manage or manipulate PDFs.
+By being Pure-Python, it should run on any Python platform without
+any dependencies on external libraries. It can also work entirely
+on StringIO objects rather than file streams, allowing for PDF
+manipulation in memory. It is therefore a useful tool for websites
+that manage or manipulate PDFs.
-NOTE: This is a fork of pyPdf, which is available on SBo separately.
+NOTE: This is a fork of pyPdf, which is available on SBo separately.
diff --git a/python/PyPDF2/slack-desc b/python/PyPDF2/slack-desc
index eaa7bfc90a..a625170a5c 100644
--- a/python/PyPDF2/slack-desc
+++ b/python/PyPDF2/slack-desc
@@ -12,7 +12,7 @@ PyPDF2: A Pure-Python library built as a PDF toolkit.
PyPDF2:
PyPDF2:
PyPDF2:
-PyPDF2:
+PyPDF2: Homepage:https://pypi.org/project/PyPDF2
PyPDF2:
PyPDF2:
PyPDF2: