summaryrefslogtreecommitdiffstats
path: root/python/apsw/apsw.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/apsw/apsw.SlackBuild')
-rw-r--r--python/apsw/apsw.SlackBuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/python/apsw/apsw.SlackBuild b/python/apsw/apsw.SlackBuild
index a09966c20b..724327c7c8 100644
--- a/python/apsw/apsw.SlackBuild
+++ b/python/apsw/apsw.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for apsw
-# Copyright 2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2013-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=apsw
-VERSION=${VERSION:-3.7.17_r1}
+VERSION=${VERSION:-3.13.0_r1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,15 +50,15 @@ unzip $CWD/$PRGNAM-${VERSION/_/-}.zip
cd $PRGNAM-${VERSION/_/-}
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build --enable-all-extensions
python setup.py install --root=$PKG --skip-build
-if $(python3 -c 'import os' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py build --enable-all-extensions
python3 setup.py install --root=$PKG --skip-build
fi