summaryrefslogtreecommitdiffstats
path: root/python/egenix-mx-base
diff options
context:
space:
mode:
Diffstat (limited to 'python/egenix-mx-base')
-rw-r--r--python/egenix-mx-base/README3
-rw-r--r--python/egenix-mx-base/egenix-mx-base.SlackBuild71
-rw-r--r--python/egenix-mx-base/egenix-mx-base.info10
-rw-r--r--python/egenix-mx-base/slack-desc19
4 files changed, 0 insertions, 103 deletions
diff --git a/python/egenix-mx-base/README b/python/egenix-mx-base/README
deleted file mode 100644
index 42a42511c8..0000000000
--- a/python/egenix-mx-base/README
+++ /dev/null
@@ -1,3 +0,0 @@
-This is the eGenix-mx Base Distribution for Python.
-It includes mxDateTime, mxTextTools, mxProxy, mxTools,
-mxBeeBase, mxStack, mxQueue, mxURL, and mxUID.
diff --git a/python/egenix-mx-base/egenix-mx-base.SlackBuild b/python/egenix-mx-base/egenix-mx-base.SlackBuild
deleted file mode 100644
index 03f6539f72..0000000000
--- a/python/egenix-mx-base/egenix-mx-base.SlackBuild
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for egenix-mx-base
-
-# Copyright 2008-2017 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=egenix-mx-base
-VERSION=${VERSION:-3.2.9}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYRIGHT LICENSE PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/egenix-mx-base/egenix-mx-base.info b/python/egenix-mx-base/egenix-mx-base.info
deleted file mode 100644
index dbe32b3ef9..0000000000
--- a/python/egenix-mx-base/egenix-mx-base.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="egenix-mx-base"
-VERSION="3.2.9"
-HOMEPAGE="https://www.egenix.com/products/python/mxBase/"
-DOWNLOAD="https://downloads.egenix.com/python/egenix-mx-base-3.2.9.tar.gz"
-MD5SUM="b6f6612a95a857659e20968f496dfcc2"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@liwjatan.at"
diff --git a/python/egenix-mx-base/slack-desc b/python/egenix-mx-base/slack-desc
deleted file mode 100644
index d68becc01f..0000000000
--- a/python/egenix-mx-base/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-egenix-mx-base: egenix-mx-base (eGenix mx Base Distribution for python)
-egenix-mx-base:
-egenix-mx-base: This is the eGenix mx Base Distribution for Python.
-egenix-mx-base: It includes mxDateTime, mxTextTools, mxProxy, mxTools,
-egenix-mx-base: mxBeeBase, mxStack, mxQueue, mxURL, and mxUID.
-egenix-mx-base:
-egenix-mx-base: Homepage: https://www.egenix.com/products/python/mxBase/
-egenix-mx-base:
-egenix-mx-base:
-egenix-mx-base:
-egenix-mx-base: