summaryrefslogtreecommitdiffstats
path: root/python/hgsubversion/hgsubversion.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/hgsubversion/hgsubversion.SlackBuild')
-rw-r--r--python/hgsubversion/hgsubversion.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/hgsubversion/hgsubversion.SlackBuild b/python/hgsubversion/hgsubversion.SlackBuild
index 51195a48df..9e2edfee5a 100644
--- a/python/hgsubversion/hgsubversion.SlackBuild
+++ b/python/hgsubversion/hgsubversion.SlackBuild
@@ -49,7 +49,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG