summaryrefslogtreecommitdiffstats
path: root/python/httplib2/httplib2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/httplib2/httplib2.SlackBuild')
-rw-r--r--python/httplib2/httplib2.SlackBuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/python/httplib2/httplib2.SlackBuild b/python/httplib2/httplib2.SlackBuild
index 29c73bb9b6..10c3dc9cd9 100644
--- a/python/httplib2/httplib2.SlackBuild
+++ b/python/httplib2/httplib2.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for httplib2
-# Copyright 2013-2018 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2013-2019 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=httplib2
-VERSION=${VERSION:-0.9.2}
+VERSION=${VERSION:-0.11.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -61,7 +61,7 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+rm -rf $PRGNAM-$VERSION $PRGNAM-$VERSION-2
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
@@ -71,15 +71,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix ssl hostname mismatch.
-patch -p1 < $CWD/ssl_hostname.diff
# Use system ca-certificates.crt.
patch -p1 < $CWD/use_system_cacerts.patch
+cp -a ../$PRGNAM-$VERSION ../$PRGNAM-$VERSION-2
+
python setup.py install --root=$PKG
if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
+ ( cd ../$PRGNAM-$VERSION-2
+ sed -i "s|raise socket\.error, msg|raise socket_err|" python*/httplib2/__init__.py || exit 1
+ python3 setup.py install --root=$PKG )
fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \