summaryrefslogtreecommitdiffstats
path: root/python/imagesize/imagesize.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/imagesize/imagesize.SlackBuild')
-rw-r--r--python/imagesize/imagesize.SlackBuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/python/imagesize/imagesize.SlackBuild b/python/imagesize/imagesize.SlackBuild
index 4b9a50d00f..bf2370fa93 100644
--- a/python/imagesize/imagesize.SlackBuild
+++ b/python/imagesize/imagesize.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for imagesize
-# Copyright 2017,2018 Nikos Giotis <nikos.giotis@gmail.com>, Athens, GR
+# Copyright 2017-2020 Nikos Giotis <nikos.giotis@gmail.com>, Athens, GR
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=imagesize
-VERSION=${VERSION:-0.7.1}
+VERSION=${VERSION:-1.4.1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -71,7 +81,7 @@ find -L . \
python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
+if python3 -c 'import sys' 2>/dev/null; then
python3 setup.py install --root=$PKG
fi
@@ -86,4 +96,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE