summaryrefslogtreecommitdiffstats
path: root/python/lxml/lxml.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/lxml/lxml.SlackBuild')
-rw-r--r--python/lxml/lxml.SlackBuild26
1 files changed, 23 insertions, 3 deletions
diff --git a/python/lxml/lxml.SlackBuild b/python/lxml/lxml.SlackBuild
index ee31f1b665..3dcf1f5b42 100644
--- a/python/lxml/lxml.SlackBuild
+++ b/python/lxml/lxml.SlackBuild
@@ -1,9 +1,29 @@
#!/bin/sh
+
# Slackware build script for lxml
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=lxml
-VERSION=${VERSION:-3.1.1}
+VERSION=${VERSION:-3.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,7 +66,7 @@ find . \
-exec chmod 644 {} \;
python setup.py build --with-unicode-strings
-python setup.py install --skip-build --root=$PKG
+python setup.py install --skip-build --root=$PKG --single-version-externally-managed
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true