summaryrefslogtreecommitdiffstats
path: root/python/python-xlib/python-xlib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-xlib/python-xlib.SlackBuild')
-rw-r--r--python/python-xlib/python-xlib.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/python-xlib/python-xlib.SlackBuild b/python/python-xlib/python-xlib.SlackBuild
index 599cffff15..c2839572ea 100644
--- a/python/python-xlib/python-xlib.SlackBuild
+++ b/python/python-xlib/python-xlib.SlackBuild
@@ -32,7 +32,11 @@ rm -rf $PRGNAM-$VERSION
tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
cd $PRGNAM-$VERSION || exit 1
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root $PKG || exit 1