summaryrefslogtreecommitdiffstats
path: root/python/python3-django/python3-django.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-django/python3-django.SlackBuild')
-rw-r--r--python/python3-django/python3-django.SlackBuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/python/python3-django/python3-django.SlackBuild b/python/python3-django/python3-django.SlackBuild
index b3c79e0970..990dc76cae 100644
--- a/python/python3-django/python3-django.SlackBuild
+++ b/python/python3-django/python3-django.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python3-django
-# Copyright 2018-2020 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2018-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python3-django
SRCNAM=$(echo $PRGNAM | cut -c9-14)
-VERSION=${VERSION:-3.0.3}
+VERSION=${VERSION:-4.2.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +39,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -73,9 +83,9 @@ find -L . \
python3 setup.py install --root=$PKG
# Install bash completion file
-mkdir -p $PKG/etc/bash_completion.d
-install -D -m0744 extras/${SRCNAM}_bash_completion \
- $PKG/etc/bash_completion.d/${SRCNAM}_bash_completion
+mkdir -p $PKG/usr/share/bash-completion/completions
+install -D -m0644 extras/${SRCNAM}_bash_completion \
+ $PKG/usr/share/bash-completion/completions/${SRCNAM}
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS CONTRIBUTING.rst INSTALL LICENSE README.rst \
@@ -86,4 +96,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE