summaryrefslogtreecommitdiffstats
path: root/python/python3-ipython/python3-ipython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-ipython/python3-ipython.SlackBuild')
-rw-r--r--python/python3-ipython/python3-ipython.SlackBuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/python/python3-ipython/python3-ipython.SlackBuild b/python/python3-ipython/python3-ipython.SlackBuild
index 6195db5559..1d489fb641 100644
--- a/python/python3-ipython/python3-ipython.SlackBuild
+++ b/python/python3-ipython/python3-ipython.SlackBuild
@@ -1,9 +1,8 @@
#!/bin/sh
-# SlackBuild for IPython
+# SlackBuild for python3-ipython
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2008-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +24,7 @@
SRCNAM=ipython
PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-6.2.1}
+VERSION=${VERSION:-6.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -41,7 +40,6 @@ CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS=${DOCS:-no}
set -e
@@ -51,17 +49,20 @@ cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
-
+chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root="$PKG"
+python3 setup.py install --root=$PKG
rm $PKG/usr/bin/iptest
rm $PKG/usr/bin/ipython
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mkdir -p $PKG/usr/man/man1
mv $PKG/usr/share/man/man1/$SRCNAM.1 $PKG/usr/man/man1/${SRCNAM}3.1
find $PKG/usr/man -type f -exec gzip -9 {} \;
@@ -71,8 +72,9 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
rm -rf $PKG/usr/share
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-
-cp COPYING.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp \
+ COPYING.rst README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install