summaryrefslogtreecommitdiffstats
path: root/python/python3-pandas/python3-pandas.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pandas/python3-pandas.SlackBuild')
-rw-r--r--python/python3-pandas/python3-pandas.SlackBuild47
1 files changed, 27 insertions, 20 deletions
diff --git a/python/python3-pandas/python3-pandas.SlackBuild b/python/python3-pandas/python3-pandas.SlackBuild
index 443a4e5c80..33a8406941 100644
--- a/python/python3-pandas/python3-pandas.SlackBuild
+++ b/python/python3-pandas/python3-pandas.SlackBuild
@@ -1,8 +1,10 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python3-pandas
# Copyright 2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2022 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +24,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python3-pandas
SRCNAM=pandas
-VERSION=${VERSION:-0.25.3}
+VERSION=${VERSION:-2.1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,25 +41,15 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -70,14 +65,26 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# remove requirement
+sed -i '/oldest-supported-numpy/d' pyproject.toml
+
+# convert to minimum req'd instead of pinned
+sed -i 's/meson-python==/meson-python>=/' pyproject.toml
+sed -i 's/meson==/meson>=/' pyproject.toml
+
+# needs newer meson
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+# cannot build sdist, specify just wheel
+python3 -m build --wheel --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE README.md \
+ AUTHORS.md LICENSE PKG-INFO README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -85,4 +92,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE