summaryrefslogtreecommitdiffstats
path: root/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild')
-rw-r--r--python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild40
1 files changed, 21 insertions, 19 deletions
diff --git a/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild b/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild
index e1937e1790..2a8ceb724d 100644
--- a/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild
+++ b/python/sphinx-rtd-theme/sphinx-rtd-theme.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# SlackBuild build script for sphinx_rtd_theme
-# Copyright (c) 2000-2020 Prof. Horstmann <wmh (at) eipg.fr>
+# Copyright 2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright (c) 2000-2011 Pr. Horstmann <wmh (at) eipg.fr>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,13 +23,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240322 46and2: Updated version, new maintainer.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=sphinx-rtd-theme
-PKGNAM=sphinx_rtd_theme
-VERSION=${VERSION:-0.4.3}
+VERSION=${VERSION:-2.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM="$(printf $PKGNAM | cut -d- -f2-)"
+SRCNAM=$( printf $PRGNAM | tr - _ )
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -38,15 +43,19 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
-TMP=${TMP:-/tmp}
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
rm -rf $PKG
-mkdir -p $TMP $PKG
+mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
@@ -54,18 +63,11 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
- # Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
-fi
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
@@ -75,4 +77,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE