summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/pyjwt/README3
-rw-r--r--python/pyjwt/pyjwt.SlackBuild74
-rw-r--r--python/pyjwt/pyjwt.info10
-rw-r--r--python/pyjwt/slack-desc19
4 files changed, 106 insertions, 0 deletions
diff --git a/python/pyjwt/README b/python/pyjwt/README
new file mode 100644
index 0000000000..21fcd9d904
--- /dev/null
+++ b/python/pyjwt/README
@@ -0,0 +1,3 @@
+PyJWT is a Python library which allows you to encode and decode JSON Web
+Tokens (JWT). JWT is an open, industry-standard (RFC 7519) for representing
+claims securely between two parties.
diff --git a/python/pyjwt/pyjwt.SlackBuild b/python/pyjwt/pyjwt.SlackBuild
new file mode 100644
index 0000000000..8623128371
--- /dev/null
+++ b/python/pyjwt/pyjwt.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+
+# Slackware build script for PyJWT
+
+# Copyright 2016 Andre Barboza, Belo Horizonte - Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyjwt
+VERSION=${VERSION:-1.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG.md LICENSE MANIFEST.in README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyjwt/pyjwt.info b/python/pyjwt/pyjwt.info
new file mode 100644
index 0000000000..691e15431a
--- /dev/null
+++ b/python/pyjwt/pyjwt.info
@@ -0,0 +1,10 @@
+PRGNAM="pyjwt"
+VERSION="1.4.2"
+HOMEPAGE="https://github.com/jpadilla/pyjwt"
+DOWNLOAD="https://github.com/jpadilla/pyjwt/archive/1.4.2/pyjwt-1.4.2.tar.gz"
+MD5SUM="f410b3940a01366312e121e034ef8eea"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="cryptography pycrypto ecdsa"
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
diff --git a/python/pyjwt/slack-desc b/python/pyjwt/slack-desc
new file mode 100644
index 0000000000..0dbd53809c
--- /dev/null
+++ b/python/pyjwt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyjwt: pyjwt (JSON Web Token implementation in Python)
+pyjwt:
+pyjwt: A Python implementation of RFC 7519.
+pyjwt:
+pyjwt:
+pyjwt:
+pyjwt:
+pyjwt:
+pyjwt:
+pyjwt: Homepage: https://pyjwt.readthedocs.org
+pyjwt: