summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/simplejson/simplejson.SlackBuild9
-rw-r--r--python/simplejson/simplejson.info6
2 files changed, 7 insertions, 8 deletions
diff --git a/python/simplejson/simplejson.SlackBuild b/python/simplejson/simplejson.SlackBuild
index 58b75434da..fc80541387 100644
--- a/python/simplejson/simplejson.SlackBuild
+++ b/python/simplejson/simplejson.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for simplejson
-# Copyright 2009-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=simplejson
-VERSION=${VERSION:-3.8.1}
+VERSION=${VERSION:-3.8.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -58,8 +58,7 @@ find -L . \
# Make documents if Sphinx and Pygments are installed.
if $(python -c 'import sphinx.pygments_styles' 2>/dev/null); then
python scripts/make_docs.py
- rm -f docs/.buildinfo
- rm -f docs/.nojekyll
+ rm -f docs/.buildinfo docs/.nojekyll docs/objects.inv
fi
python setup.py install --root=$PKG
@@ -74,7 +73,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a {CHANGES,LICENSE}.txt README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-[ -d docs ] && (rm -f docs/objects.inv; cp -ar docs $PKG/usr/doc/$PRGNAM-$VERSION)
+[ -d docs ] && cp -ar docs $PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/python/simplejson/simplejson.info b/python/simplejson/simplejson.info
index dad1f06c4b..3610c0f147 100644
--- a/python/simplejson/simplejson.info
+++ b/python/simplejson/simplejson.info
@@ -1,8 +1,8 @@
PRGNAM="simplejson"
-VERSION="3.8.1"
+VERSION="3.8.2"
HOMEPAGE="https://github.com/simplejson/simplejson"
-DOWNLOAD="http://pypi.python.org/packages/source/s/simplejson/simplejson-3.8.1.tar.gz"
-MD5SUM="b8441f1053edd9dc335ded8c7f98a974"
+DOWNLOAD="http://pypi.python.org/packages/source/s/simplejson/simplejson-3.8.2.tar.gz"
+MD5SUM="53b1371bbf883b129a12d594a97e9a18"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""