summaryrefslogtreecommitdiffstats
path: root/system/I-Nex/I-Nex.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/I-Nex/I-Nex.SlackBuild')
-rw-r--r--system/I-Nex/I-Nex.SlackBuild52
1 files changed, 38 insertions, 14 deletions
diff --git a/system/I-Nex/I-Nex.SlackBuild b/system/I-Nex/I-Nex.SlackBuild
index a094087108..246848795d 100644
--- a/system/I-Nex/I-Nex.SlackBuild
+++ b/system/I-Nex/I-Nex.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for I-Nex
@@ -22,10 +22,23 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220331 bkw: Modified by SlackBuilds.org, BUILD=3:
+# - don't install .desktop files +x.
+# - make /usr/bin/i-nex symlink relative.
+
+# 20220212 bkw: Modified by SlackBuilds.org: BUILD=2.
+# - add -j1 to 'make install' to avoid breaking parallel builds.
+# - fix the .desktop files
+# - install the rest of the docs (AUTHORS, ChangeLog).
+# - don't install useless INSTALL to doc dir.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=I-Nex
-VERSION=${VERSION:-7.6.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-7.6.1}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +48,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -65,15 +82,12 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-sed -i 's|python3$|python2|' pastebinit
sed -i -e 's|^STATIC.*|STATIC = false|' i-nex.mk
-patch -p1 -i $CWD/I-Nex_fix.patch
-
cd $PRGNAM
autoreconf --install
@@ -89,15 +103,25 @@ CFLAGS="$SLKCFLAGS" \
cd ..
make
-make install DESTDIR=$PKG
+make -j1 install DESTDIR=$PKG
+strip $PKG/usr/bin/i-nex-edid
+
+# the shipped .desktop files don't validate, and are silly. also they
+# get installed executable...
+rm -f $PKG/usr/share/applications/*
+for i in $CWD/*.desktop; do
+ cat $i > $PKG/usr/share/applications/$( basename $i )
+done
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20220331 bkw: this symlink should be relative, not absolute.
+rm -f $PKG/usr/bin/i-nex
+ln -s i-nex.gambas $PKG/usr/bin/i-nex
+rm -rf $PKG/usr/share/doc
mv $PKG/usr/share/man/ $PKG/usr/
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $PRGNAM/COPYING $PRGNAM/INSTALL $PRGNAM/README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $PRGNAM/{AUTHORS,COPYING,ChangeLog,README} $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -105,4 +129,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE