summaryrefslogtreecommitdiffstats
path: root/system/ZoneMinder/patches/02_destdir-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/ZoneMinder/patches/02_destdir-fix.patch')
-rw-r--r--system/ZoneMinder/patches/02_destdir-fix.patch19
1 files changed, 10 insertions, 9 deletions
diff --git a/system/ZoneMinder/patches/02_destdir-fix.patch b/system/ZoneMinder/patches/02_destdir-fix.patch
index 759e3e494f..ffc7415796 100644
--- a/system/ZoneMinder/patches/02_destdir-fix.patch
+++ b/system/ZoneMinder/patches/02_destdir-fix.patch
@@ -1,15 +1,16 @@
---- ZoneMinder-1.24.2/Makefile.am.orig 2006-12-25 01:21:07.000000000 +0000
-+++ ZoneMinder-1.24.2/Makefile.am 2006-12-25 01:22:04.000000000 +0000
-@@ -23,9 +23,9 @@
+diff -Naur ZoneMinder-r3649.orig/Makefile.am ZoneMinder-r3649/Makefile.am
+--- ZoneMinder-r3649.orig/Makefile.am 2011-05-20 11:46:14.321490000 +0200
++++ ZoneMinder-r3649/Makefile.am 2012-06-20 14:55:04.474019380 +0200
+@@ -21,9 +21,9 @@
# Yes, you are correct. This is a HACK!
install-data-hook:
( cd $(DESTDIR)$(sysconfdir); chown $(webuser):$(webgroup) $(sysconf_DATA); chmod 600 $(sysconf_DATA) )
-- -( if ! test -e $(RUNDIR); then mkdir $(RUNDIR); fi )
-- ( if ! test -e $(ZM_RUNDIR); then mkdir $(ZM_RUNDIR); fi; chown $(webuser):$(webgroup) $(ZM_RUNDIR); chmod u+w $(ZM_RUNDIR) )
-+ -( if ! test -e $(DESTDIR)$(RUNDIR); then @mkdir_p@ $(DESTDIR)$(RUNDIR); fi )
-+ ( if ! test -e $(DESTDIR)$(ZM_RUNDIR); then @mkdir_p@ $(DESTDIR)$(ZM_RUNDIR); fi; chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_RUNDIR); chmod u+w $(DESTDIR)$(ZM_RUNDIR) )
+- ( if ! test -e $(ZM_RUNDIR); then mkdir -p $(ZM_RUNDIR); fi; if test "$(ZM_RUNDIR)" != "/var/run"; then chown $(webuser):$(webgroup) $(ZM_RUNDIR); chmod u+w $(ZM_RUNDIR); fi )
+- ( if ! test -e $(ZM_TMPDIR); then mkdir -m 700 -p $(ZM_TMPDIR); fi; if test "$(ZM_TMPDIR)" != "/tmp"; then chown $(webuser):$(webgroup) $(ZM_TMPDIR); chmod u+w $(ZM_TMPDIR); fi )
+- ( if ! test -e $(ZM_LOGDIR); then mkdir -p $(ZM_LOGDIR); fi; if test "$(ZM_LOGDIR)" != "/var/log"; then chown $(webuser):$(webgroup) $(ZM_LOGDIR); chmod u+w $(ZM_LOGDIR); fi )
++ ( if ! test -e $(DESTDIR)$(ZM_RUNDIR); then mkdir -p $(DESTDIR)$(ZM_RUNDIR); fi; if test "$(ZM_RUNDIR)" != "/var/run"; then chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_RUNDIR); chmod u+w $(DESTDIR)$(ZM_RUNDIR); fi )
++ ( if ! test -e $(DESTDIR)$(ZM_TMPDIR); then mkdir -m 700 -p $(DESTDIR)$(ZM_TMPDIR); fi; if test "$(ZM_TMPDIR)" != "/tmp"; then chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_TMPDIR); chmod u+w $(DESTDIR)$(ZM_TMPDIR); fi )
++ ( if ! test -e $(DESTDIR)$(ZM_LOGDIR); then mkdir -p $(DESTDIR)$(ZM_LOGDIR); fi; if test "$(ZM_LOGDIR)" != "/var/log"; then chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_LOGDIR); chmod u+w $(DESTDIR)$(ZM_LOGDIR); fi )
uninstall-hook:
@-( cd $(DESTDIR)$(webdir); rm -rf events graphics images sounds temp )
-- @-( rm -rf $(ZM_RUNDIR) )
-+ @-( rm -rf $(DESTDIR)$(ZM_RUNDIR) )