summaryrefslogtreecommitdiffstats
path: root/system/hercules
diff options
context:
space:
mode:
Diffstat (limited to 'system/hercules')
-rw-r--r--system/hercules/hercules.SlackBuild19
-rw-r--r--system/hercules/hercules.info6
-rw-r--r--system/hercules/moddir.patch11
3 files changed, 13 insertions, 23 deletions
diff --git a/system/hercules/hercules.SlackBuild b/system/hercules/hercules.SlackBuild
index 63dea84a6a..052a73b9ec 100644
--- a/system/hercules/hercules.SlackBuild
+++ b/system/hercules/hercules.SlackBuild
@@ -4,12 +4,12 @@
# the System/370, ESA/390 and z/Architecture emulator
# Written by Niels Horn - niels.horn@gmail.com
-# revision date 2009/12/19
+# revision date 2010/03/10
set -e
PRGNAM=hercules
-VERSION=${VERSION:-svn_20091219}
+VERSION=${VERSION:-3.07}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -22,12 +22,19 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
+ ARCHQUADLET=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
+ ARCHQUADLET=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+ ARCHQUADLET=""
+elif [ "$ARCH" = "arm" ]; then
+ SLKCFLAGS="-O2 -march=armv4t"
+ LIBDIRSUFFIX=""
+ ARCHQUADLET="-gnueabi"
fi
rm -rf $TMP/$PRGNAM-$VERSION $PKG
@@ -38,12 +45,6 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# Apply patch to resolve directory of Hercules modules in x86_64
-patch -p1 < $CWD/moddir.patch
-
-# Generate configure etc. first...
-sh autogen.sh
-
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -53,7 +54,7 @@ CFLAGS="$SLKCFLAGS" \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-external-gui \
- --build=$ARCH-slackware-linux
+ --build=$ARCH-slackware-linux$ARCHQUADLET
make
make install DESTDIR=$PKG
diff --git a/system/hercules/hercules.info b/system/hercules/hercules.info
index fa3a0b4dec..457a1e6422 100644
--- a/system/hercules/hercules.info
+++ b/system/hercules/hercules.info
@@ -1,10 +1,10 @@
PRGNAM="hercules"
VERSION="svn_20091219"
HOMEPAGE="http://www.hercules-390.org/"
-DOWNLOAD="http://www.nielshorn.net/_download/hercules-svn_20091219.tar.gz"
-MD5SUM="1f48dbcfedcb098e7223dddc82915b9b"
+DOWNLOAD="http://www.hercules-390.org/hercules-3.07.tar.gz"
+MD5SUM="a12aa1645b0695b25b7fc0c9a3ccab3a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Niels Horn"
EMAIL="niels.horn@gmail.com"
-APPROVED="dsomero"
+APPROVED="Erik Hanson"
diff --git a/system/hercules/moddir.patch b/system/hercules/moddir.patch
deleted file mode 100644
index ade0662da4..0000000000
--- a/system/hercules/moddir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- hercules-svn_20091219.orig/configure.ac 2009-12-19 09:41:19.000000000 -0200
-+++ hercules-svn_20091219/configure.ac 2009-12-19 13:35:17.000000000 -0200
-@@ -1809,7 +1809,7 @@
- fi
- fi
-
--MODULESDIR="${DESTPREFIX}/lib/${PACKAGE}"
-+MODULESDIR="${libdir}/${PACKAGE}"
- PKGDATADIR="${DESTPREFIX}/share/${PACKAGE}"
- HERC_LOCALEDIR="${DESTPREFIX}/share/locale"
-