summaryrefslogtreecommitdiffstats
path: root/system/lshw/lshw.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/lshw/lshw.SlackBuild')
-rw-r--r--system/lshw/lshw.SlackBuild75
1 files changed, 64 insertions, 11 deletions
diff --git a/system/lshw/lshw.SlackBuild b/system/lshw/lshw.SlackBuild
index 0b24779004..2839e24a9c 100644
--- a/system/lshw/lshw.SlackBuild
+++ b/system/lshw/lshw.SlackBuild
@@ -1,12 +1,47 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for lshw
-# Written by Iskar Enev <iskar.enev[@]gmail.com>
+
+# Iskar Enev <iskar.enev[@]gmail.com>
+# Copyright 2017,2021 Jason Graham <jgraham@compukix.net> USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=lshw
-VERSION=${VERSION:-B.02.18}
+VERSION=${VERSION:-B.02.19.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+GUI=${GUI:-yes}
+if [ "$ZLIB" = "no" ]; then
+ ENABLE_ZLIB=0
+else
+ ENABLE_ZLIB=1
+fi
+if [ "$SQLITE" = "no" ]; then
+ ENABLE_SQLITE=0
+else
+ ENABLE_SQLITE=1
+fi
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -16,7 +51,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -53,10 +95,19 @@ find -L . \
# Fix the MANDIR variable
sed -i "s%MANDIR=\$(PREFIX)/share/man%MANDIR=\$(PREFIX)/man%" src/Makefile
-RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" make
-RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" make gui
-make install DESTDIR=$PKG
-make install-gui DESTDIR=$PKG
+VERSION=$VERSION RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" \
+ make ZLIB=$ENABLE_ZLIB SQLITE=$ENABLE_SQLITE
+if [ "$GUI" = "yes" ]; then
+ VERSION=VERSION RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" \
+ make gui ZLIB=$ENABLE_ZLIB SQLITE=$ENABLE_SQLITE
+fi
+
+VERSION=$VERSION RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" \
+ make install DESTDIR=$PKG ZLIB=$ENABLE_ZLIB SQLITE=$ENABLE_SQLITE
+if [ "$GUI" = "yes" ]; then
+ VERSION=$VERSION RPM_OPT_FLAGS="$SLKCFLAGS" MANDIR="/usr/man" \
+ make install-gui DESTDIR=$PKG ZLIB=$ENABLE_ZLIB SQLITE=$ENABLE_SQLITE
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -64,8 +115,10 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-mkdir -p $PKG/usr/share/applications
-cat $CWD/gtk-lshw.desktop > $PKG/usr/share/applications/gtk-lshw.desktop
+if [ "$GUI" = "yes" ]; then
+ mkdir -p $PKG/usr/share/applications
+ cat $CWD/gtk-lshw.desktop > $PKG/usr/share/applications/gtk-lshw.desktop
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a docs/* COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
@@ -76,4 +129,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE