summaryrefslogtreecommitdiffstats
path: root/system/sdltrs
diff options
context:
space:
mode:
Diffstat (limited to 'system/sdltrs')
-rw-r--r--system/sdltrs/sdltrs.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/system/sdltrs/sdltrs.SlackBuild b/system/sdltrs/sdltrs.SlackBuild
index 6a85270302..88b5e381a0 100644
--- a/system/sdltrs/sdltrs.SlackBuild
+++ b/system/sdltrs/sdltrs.SlackBuild
@@ -71,7 +71,11 @@ cd $TMP
tar xvf $CWD/${PRGNAM}_$SRCVERSION.tar.gz
cd ${PRGNAM}_$SRCVERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# include -lX11 in the Makefile (sw-14.0)
sed "/^LIBS/s/= /= -lX11 /" -i src/linux/Makefile